conflicting fb hw usage nouveaufb vs EFI VGA - removing generic driver (SOLVED)

Hi all,

New here, and so new to Linux I haven’t even managed to use it yet!

Trying to install it (Linux Mint Cinnamon) on a new PC with no O/S. Have tried different versions (Mate, Ubuntu etc) but all are getting stuck at: ‘conflicting fb hw usage nouveaufb vs EFI VGA - removing generic driver’

All help very much appreciated. Always learning!

Am running:
Intel Pentium G3220 3GHz Dual Core
Nvidia GT 730 2GB
4GB RAM, 1TB Hard Drive
Gigabyte H81M-H Motherboard

Have you tried booting with the “nomodeset” kernel boot parameter ?

I haven’t. How do you do that please?

Is it the LiveCD that’s throwing that eror and refusing to boot … or are you managing to install, but then the installed version refuses to boot ?

in short are you able to boot a LiveCD to the desktop or not ?

I’ve tried an install from disk and USB, both do the same thing, and neither appears to be installing at all.

At the moment I’m assuming this is coming from the EFI BIOS and the onboard graphics adapter Vs your add in nVidai card.

Is there any way to set the EFI BIOS to “legacy BIOS” mode … and/or disable the onboard graphics card in the BIOS ?

If not, I’ll post how to try “nomodeset”

See page 24 here:

enable CSM Support
and set “Boot Mode Selection” to “Legacy Only”

then see page 26

and disable “Intel Processor Graphics”

Ok, I think I just changed something in BIOS from UEFI & Legacy to Legacy Only, after which I tried booting from LiveCD again. This time it started a Linux Mint display with a boot countdown. After that I’m shown a white screen with a blinking cursor at the top left. Keys are unresponsive and it seems stuck there.

See the edit above … try disabling the “Intel Processor Graphics” in the EFI BIOS too.

Oh wow! Just disabled the Intel Graphics and it started to install! Now I have Linux!! Thank you SO much for all of your help.

One last thing though, do I need to switch the Intel Graphics back on, or just run the nVidia driver disk now?

Thanks again :slight_smile:

I’d leave the Intel graphics off :wink:

the nVidia driver disk is only likely to contain Windows drivers.

Can you search the menu for "Additional “Drivers” … run it … and post what’s listed, and what’s currently selected.

If I searched in the right place (the search bar within the menu) - that brought up Driver Manager, which says ‘No proprietary drivers are in use.’

Are we talking about Linux Mint ?

Can you open a terminal and run:

sudo lshw -C display

and post the output back here.

Be aware, that Linux commands ARE case sensitive, so that’s a capital C
(it may be easier to copy/paste the command into the terminal)

Also that command will ask for your password … when entering your password in a Linux terminal nothing will be echoed to screen (not even ******) but it is going in, so just type your password and hit enter.

Yes, Linux Mint Cinnamon.

Here’s what came up:

*-display UNCLAIMED
description: VGA compatible controller
product: NVIDIA Corporation
vendor: NVIDIA Corporation
physical id: 0
bus info: pci@0000:01:00.0
version: a1
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress vga_controller cap_list
configuration: latency=0
resources: memory:f2000000-f2ffffff memory:e8000000-efffffff memory:f0000000-f1ffffff ioport:e000(size=128) memory:f3000000-f307ffff

What’s the output from:

lspci -vnn | grep -i vga

That produces this:

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation Device [10de:1287] (rev a1) (prog-if 00 [VGA controller])

OK, looks like you need the nvidia 340 driver (GT 730 was added in 331.89) … this isn’t in the default repositories by default.

There’s 2 options here

a) download and install them from nvidia
b) add the xorg-edgers PPA

couple of questions first

i) What’s the output from:

uname -a


ii) Are you game to reinstall if this all goes wrong ?


iii) Have you got a working internet connection under Mint yet ?

Hi Mark,

I do have internet connected, and if a reinstall is needed, so be it. :slight_smile:

Downloaded from nVidia, tried to run it and get this msg:

Could not open the file /home/raxial/Downloads/N…

Search engined about .run files and tried going into Properties/Permissions and ticking ‘Allow executing file as program’ then double clicked it. Still comes up the same and won’t run.

uname -a shows this:

Linux Skynet 3.13.0-24-generic #46-Ubuntu SMP Thu Apr 10 19:11:08 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux


OK, from what I gather you cannot install the nvidia driver that you downloaded from nvidia with X running … so you’d need to mark the .run file as executable, then stop X, and whilst in text only mode install the driver from the command line.

I can talk you through that … but I’m thinking it may just be easier to add the xorg-edgers PPA, update the package cache, then see what “Driver Manager” offers you.

Do you want to give that a shot first … if so, just say so and I’ll talk you through that too.

Which method do you want to try first … downloaded driver, or xorg-edgers PPA ?

Whichever you think a noob might find easiest to follow? :wink:

Thank you Mark. I have to go out now but if you can post an ‘aimed at a four year-old’ how-to I’ll try it out later.
Again, really appreciate all your help.

Sod it, we’ll try going with the driver you downloaded from the nVidia website first…

OK, first thing you need to do is make sure you’re completely up to date, and add a couple of packages

So open a terminal and run these commands in sequence:

sudo apt-get update


sudo apt-get upgrade


sudo apt-get dist-upgrade

When that last command completes (and leaves you back at an $ prompt) REBOOT ← this is important to load any new kernel that came with the updates

Once rebooted, open a terminal and run:

sudo apt-get install linux-headers-generic build-essential dkms

OK, now write the next instructions down (or have them on another PC) as you’ll not have a graphical front end whilst installing the drivers.

Hit Ctrl+Alt+F3 … this will drop you to a text console (black screen with text).

in the console, log on by typing raxial and hitting enter
then enter your password and hit enter.

Once logged on and at an $ prompt, run these commands in sequence:

chmod +x /home/raxial/Downloads/


sudo service mdm stop


sudo apt-get purge nvidia*


sudo sh /home/raxial/Downloads/

and follow any onscreen instructions.

When that finishes (if the system hasn’t already rebooted), run:

sudo service mdm start

to restart the desktop.

DO NOT delete the installer file ( yet … we may need it to uninstall the driver if anything goes wrong.

And remember … Linux commands ARE case sensitive.

If that all goes well, and you’re now back at the desktop, open a terminal and post the output from:

sudo lshw -C display

so I can check if it’s using the correct driver now.