HP Deskjet 3070A

I have just (honest, literally) converted to Ubuntu and need help with my printer.

On a sidenote; I can’t believe my luck that HP’s are such well supported printers, having just binned a Lexmark X1150 All-In-One, which was around 7 years old, Only binning it due to the fact that I couldn’t get it to re-install onto my XP Pro OS.
Due to that, I bought the HP Deskjet 3070A.

What my problem now is, I cant scan with it (not even tried printing yet) but it is in the list of printers, I cant see the scan option (where do I look).
So I went to the HP site and had a look to see if I could get the latest full install SW for it but when I found it, I was well over my head as the install was to me (an ex Windows user) very daunting, so I gave up.
And the fact that it didn’t support the version of Ubuntu I have, which is 11.10 and the supplied version was 11.04. I didn’t want to fubar my new OS so soon.


Do you know how to install software from either of the package managers (Synaptic, or the Ubuntu Software Centre) ? … or from the command line ?

If not, open a terminal by hitting Ctrl+Alt+T (at the same time), then when the terminal opens, enter:

sudo apt-get install hplip-gui xsane

hit enter, and your password when asked.

Be aware, you will not see anything echoed to screen when you type your password (not even *****) but it IS going in.

once that command has finished and you are back at a $ prompt … you can close the terminal.

Then on the launcher bar on the left, click the “Application Lens” (magnifying glass with + in it) …then search for HP Toolbox you will be able to set up your printer from there (I think you can scan from there too).

If you cannot scan from the HP Toolbox … do the same thing, but search for Xsane instead … Xsane is the primary Linux scanner interface.

Sorry, it’s all new to me (Windows convert).
I have just found the HP Device Manager and the deskjet 3070A is not on the list so it’s not installed yet.
(Just installed it but it couldnt find 3070 so gave me 3050 instead, hope that has scan too)
I have the disk that came with it but don’t know how to use it on this OS, I put it in and closed the drawer but Ubuntu didn’t do anything with it?

Ignore the CD it is unlikely to contain any Linux drivers … the easiest way would be to do what I just said.

DO NOT download an installer from the internet (that’s a bad windows habit, and usually unnecessary with Linux) … use your package manager(s) which will download it and install it for you.

ALWAYS check if the software you want is in your package managers first

well, had a look and it is installed but so scan function available (probably due to being 305 driver and not 4070.


According to the launchpad, the 3070a is supported in hplip 3.11.10 (using the HP3070 b611 drivers) … but currently Ubuntu 11.10 is using version 3.11.7.

So it looks like you are going to have to upgrade hplip.

I’m currently checking for the easiest way to achieve this and will post back with instruction when I’ve worked it out.

You ARE on Ubuntu 11.10 aren’t you ?

Yes, I have the latest version installed, 11.10


OK there is no PPA for hplip 3.11.10 so there’s no way to do this except from the command line I’m afraid.

In Ubuntu 11.10 64bit they have made a separate 64bit library path:- /usr/lib64/ … In previous versions of Ubuntu they had a soft symlink to /usr/lib from /usr/lib64 (/usr/lib64 → /usr/lib).

This section is ONLY necessary if you are running 11.10 64bit

So if you are running 11.10 64bit, first you need to make an edit to ~/.bashrc … so open a terminal and enter:

gedit ~/.bashrc

When gedit opens, add thes 2 lines to the bottom of the file:-


Visually check the 2 lines, then SAVE the file, and exit gedit.


From this point onwards the instructions are for both 64bit AND 32bit versions of Ubuntu 11.10

OK, now to download hplip-3.11.10.run … go to this webpage:

and click the Download HPLIP button … on the next page click the Download HPLIP button again.

This should download the hplip-3.11.10.run file to your Downloads directory (if it downloads anywhere else, place it in your Downloads directory).

Once it’s downloaded, and in your Downloads directory … open a terminal and enter:

cd ~/Downloads


sh hplip-3.11.10.run

Now follow the onscreen instructions (when asked for install type, type “a” for automatic, and hit enter).

I’ve followed the instructions but it keeps coming up with;
error:hp-setup failed. Please run hp-setup manually.
…How do I do that ?
Any idea what’s wrong?

Are you running 64bit ubuntu … if unsure, open a terminal and enter:

uname -a

and post back the output

Linux Petes-ubuntu-pc #20-ubuntu smp Fri Oct 7 14:56:25 UTC 201 1 x86_64 x86_64 x86_64 GNU/Linux

OK it IS 64bit … did you do the top section and reboot … the reboot IS important

if not … do it now, then REBOOT … then open a terminal and enter:


Done that… and get this
Traceback (most recent call last):
File “/usr/bin/hp-setup”, line 45, in
from base import device, utils, tui, models,module
File “/usr/share/hplip/base/device.py”, line 39, in
import status
File “/usr/share/hplip/base/status.py”, line 45, in
import hpmudest
ImportError: libhpmud.so.0: cannot open shared object file: No such file or directory

Any help?

OK I just copy/pasted the extra 2 lines into the .bashrc file … and for some reason it ended up with an extra space in it.

run this:

gedit ~/.bashrc

and VISUALLY check the last 2 lines read:-




then save the file … REBOOT … and run:


It DID put a space in PATH (the second one)
Then I changed it and rebooted, tried again… FAILED
So I re-checked… it put a space in the first one this time…
Fixed that one and now it’s installed… But (There HAD to be one of those somewhere)
How do I access my printer and scan?


Mentioned earlier was a program called xsane, I have found that and it says not found

Is the printer not available in the applications themselves when you select print ?

and does the scanner not show up in xsane or simple scan ?

LibreOffice can see it.
I downlaoded HP Device Manager and that cant see it, do I need a reboot for it to?
No, xsane can’t see it either

I’ll have another look at this tomorrow … need sleep now though :slight_smile:

Thats ok, I’m thinking the same :slight_smile:

Can you open a terminal and enter:


and hit enter.

Once the test is finished, run:

gedit ~/hp-check.log

and hit enter.

Then post the contents of that file back here … when you post it, please surround it with [/spoiler] tags, as it will be quite large.