HP Vista Laptop conversion

I wish to install Linux on my laptop & remove XP
The only concern I have is that HP have software (for touchpad, internet, sound, graphics &c…) & I am unsure whether it’ll be compatible
Is there anyway of moving/saving the necessary files for these operation so they operate with Linux?
Sorry, bit of a noob when it comes to PCs

(",)

The only concern I have is that HP have software (for touchpad, internet, sound, graphics &c...) & I am unsure whether it'll be compatible

Firstly, the Windows drivers won’t work in Linux… not a problem, Linux contains its own drivers… most if not all of the devices you mention will probably “just work” without the need for you to manually install any drivers.

Secondly, neither will Windows software… so though things like M$ Office aren’t going to run in Linux, there are nearly always Linux alternatives (99.999% of which are free)… for example, LibreOffice will be able to read/edit/write your M$ Office docs etc. and will come pre-instaled in most Linux distributions.

But if you want to “test drive” Linux, why not download a LiveCD ISO image, burn it to a CDR or DVD-R, then boot to it, and select “Try Ubuntu”.

A LiveCD will boot to a working Linux desktop without making ANY changes to your hard drive… you can then test compatibility, and get a “feel” for Linux without changing your Windows setup at all.
(though obviously it will be slower than a hard drive installation, and you won’t be able to save any changes)

May I suggest Ubuntu:

download the LiveCD image from here:
http://www.ubuntu.com/download/ubuntu/download

To burn the ISO image to a blank CD/DVD, Your best bet would be to download ImgBurn on your Windows box (it’s free):

http://download.imgburn.com/SetupImgBurn_2.5.2.0.exe

Install it, then see here for instructions on how to burn an image with ImgBurn:

on the second picture, where it says Write Speed: AUTO … change that to 4X
and put a tick in the Verify box.

If you have any further questions… just ask :wink:


[EDIT]

If you post the model of your HP laptop (usually on a sticker underneath), we may be able to check if there are any know issues with drivers etc.

Am gonna burn as LiveUSB as part of the issue with XP is no longer recognises my CD-Drive :frowning:
I guess I can run from USB & see what works & what doesn’t?
I already use OpenOffice, Firefox &c… my concern was more for things like the monitor but I should discover all that when I trial run :smiley:
If, as I’m hoping, I turn to Ubuntu how would I go around deleting XP & the filess no longer needed from it?

Laptop is HP Compaq nx6325, AMD Mobile Sempron, Vista compatible (old I know, but it hooks up to projector as 2nd monitor & surround sound, which my PC doesn’t)

(",)

Once you’ve tried Ubuntu from a LiveUSB and decided you want to erase Windows and install Ubuntu… if you select “Install Ubuntu”, at some point in the installation it will ask you how you want to partition the hard drive… just tell it to use the whole drive.

Click through the Ubuntu 11.04 installation screenshots here:
http://www.debianadmin.com/ubuntu-11-04natty-installation-screenshots-gallary.html
(BTW, I’ve just noticed those screenshots may not quite in the correct order, but you’ll get the idea)

On the 3rd screen, just select the “Erase disk and install Ubuntu” option… and it will do just that :wink:

[EDIT]

The second monitor (projector) may or may not auto-configure… if it doesn’t let us know and we’ll see if we can help… there’s nearly always an answer to these things… actually I doubt if you’ll get the second monitor to work without installing the proprietary ATI drivers, which you’ll only be able to do if you include a persistence file when you create the LiveUSB, or install Ubuntu to the hard drive.

[EDIT 2]

The only issue I’ve been able to find that occasionally pops up on a Compaq nx6325, is that the wireless adapter works fine from the LiveCD/LiveUSB, but once Ubuntu is installed to the hard drive, it no longer works.

The fix is to install the b43-fwcutter and firmware-b43-installer packages, which can either be installed through the Synaptic package magager, or by running the following command in a terminal:

sudo apt-get install b43-fwcutter firmware-b43-installer

then navigate to Additional Drivers, activate the b43 driver, and reboot.

IF you need to do this, you will have to connect the laptop to your router with an ethernet cable whilst you install those packages.

Okay trial seems okay, but can’t access my external HD to which I need to save files before installing fully.
It’s the same HD as the LiveUSB was installed to, is this why I can’t seem to find it?
I would also like to run some of the media from the HD to ensure compatability & am unable to do so as HD does not appear in lists…?

(",)

Running from a LiveCD or LiveUSB doesn’t automagically mount the hard drive(s) by default…

Open your home folder, to open the nautilus file manager, then hit Ctrl+L to open the Location dialog, then enter computer:/// and hit enter.

Or navigate to Computer in the nautilus bookmarks.

Or Places>Computer

Or if you’re running the Unity desktop (sidebar on left), Files & Folders>Computer

Either way, the hard drive(s) will be displayed… clicking one, will mount it and display its contents.

You’re going to require a second USB stick/HDD to copy your files to though… copying them to a persistence file on a LiveUSB is probably going to give you problems, and is inadvisable.

So I’ve installed Ubuntu & now my screen is black with a flashing underscore, which shuts down after 3mins!
Has there been an issue with the install?
Any ideas what do I do now, as it’s not working?

[EDIT]
Have re-installed but there is an ‘apt configuration problem’ the ‘attemp to to configure apt to install additional packages from the CD failed’
‘Installer crashed’ it tell me to attach filelogs to the crash report- but I can’t access file logs
This appears to be the issue- how should I rectify?

(",)

When do you see this flashing cursor … Immediately, or does the system boot for a while (purple(ish) screen), THEN go to a flashing cursor ?

[edit]

Have you checked the CD for errors ?

Also, if you selected the option to install the extra stuff like mp3 support etc. … did you have a wured connection to the router, as it needs to download those packages (I’m pretty sure it mentions this) ?

After inputting choice for loading (HD/USB/CD) it went straight to a black screen when taking the USB choice it went straight to the try/install screen

[EDIT]
It’s all on a USB drive, how would I check for errors?

[EDIT 2]
I was wired up & slected all updates the first time & no updates the second, first time it told me to re-boot as complete (& nothing happened upon re-boot) second time the error messages occured/were shown
Have tried for a third as hoping to rectify issue first :smiley:

(",)

OK, firstly how did you install the LiveCD image to the USB hard drive ?

and when you boot to the USB HDD, are you not offered a screen like this one ?

http://linuxforums.org.uk/MGalleryItem.php?id=1132

If not, try tapping the Shift key immediately after the BIOS post screen disappears.

When you see that screen, select Check disc for defects (or similar).

Nope totally different screen (all purpley & swishy, kinda pretty looking)
Installed LiveUSB from linuxliveusb.com & followed directions
Waiting for screen to load for install… nothing so far…

(",)

OK, I’ve never used LinuxLive USB Creator:

But it should be the same as Universal USB creator etc. … they all should just unpack the ISO image, and use syslinux as the bootloader… so I can’t see that there would be any difference in the way the LiveUSB boots.

Reboot your PC, and as soon as your screen turns purple, hit Shift… you should be presented with a screen like the one pictured above… then select “Check disc for defects”

or you could just try a re-install, but don’t select the additional packages option (fluendo etc.) … or make sure you have a wired connection to the internet.

Yep the version I was using had 1 file error
Any ideas where I can get a non-faulty version from?

(",)

It’s highly unlikely that the ISO being hosted by Canonical/Ubuntu is at fault, or loads of people would be moaning about it, and it would be quickly replaced… it’s more likely that it became corrupted during the download.

But…

I think it more likely that it was an issue when the USB creator software unpacked the ISO image to the USB HDD than an error in the ISO image itself.

The ISO can easily be tested by checking its MD5 checksum.
The MD5 for ubuntu-11.04-desktop-i386.iso
should be
8b1085bed498b82ef1485ef19074c281

You’ll find free Windows software to check the downloaded ISO files MD5 checksum here:
http://www.md5summer.org/

or to check ithe MD5 checksum in Linux, just run
md5sum /path/to/ubuntu-11.04-desktop-i386.iso

If it is correct, just recreate the LiveUSB.

If it’s incorrect, download the ubuntu-11.04-desktop-i386.iso image again.

There is a list of Ubuntu download mirrors here:

or a direct link to the canonical (http) download here:
http://releases.ubuntu.com/11.04/ubuntu-11.04-desktop-i386.iso
or a direct link to the HEAnet (ftp) download here:
http://ftp.heanet.ie/pub/ubuntu-releases/natty/ubuntu-11.04-desktop-i386.iso

Went to the canonical link to retrieve the .iso to re-make & according to the file check that also has an error in 1 file?
Which is starting to make me suspicious of where the error is coming from?
[EDIT]
The MD5 is 8b1085bed498b82ef1485ef19074c281 which is correct- I’ve re-made the Live USB & it say’s there is still an error in 1 file

(",)

Did the MD5 of the dowloaded ISO match the checksum I provided ?

if so, try a different USB creator, such as:

If not, try a different mirror.

[EDIT]

I’ve just run a “Check disc for error” on a LiveUSB, and it ALSO threw up an error in 1 file… so I’m guessing this is normal, and due to something getting edited by the USB creator software.

Okies- will re-try installation & see what happens

(",)

OK, after installing to the internal HDD, without asking for the additional software, can you describe exactly what happens when you try to boot from the internal drive… ie. how far does it seem to get ?

Does the screen turn purple ? … if so, at least the GRUB bootloader is installed, and we can edit the GRUB kernel boot line to get it to display what it’s doing as it boots, and try to get a clue as to where the boot is falling over.

It seems to install 100% then after installation it gives the 2 aforementioned error messages then freezes

(",)

Hang on a sec, I may have just found an answer… reading it now… it’s here in case you’re interested