Install Firefox 5 on an Acer Aspire One running Linpus Lite Linux

This topic is now outdated… there are now instructions for installing Firefox 7 here:

Install Firefox 7 on an Acer Aspire One running Linpus Lite Linux

For people who have ALREADY upgraded their version of Firefox 2 to Firefox 4 following the tutorial on THIS forum, see the EDIT here:

For those who HAVEN’T upgraded to Firefox 4, and are still on Firefox 2 … read on.

WARNING - DO NOT uninstall Firefox 2 prior to installing Firefox 5… on Linpus Lite this will break your system, removing Firefox 2 will also remove a lot of necessary dependencies, including half of your desktop… simply reinstalling Firefox 2 will NOT fix this… so leave Firefox 2 alone, and just follow the instructions below… none of which are irreversible :slight_smile:

To install Firefox 5.0.1 on an Acer Aspire One that is running Linpus Lite Linux as it’s operating system, and Firefox 2 as the web browser…

All commands given need to be entered into a terminal… to open a terminal, hit Alt+F2 … in the input field enter terminal and click the Run button… a terminal will open… When the terminal opens, enter the following commands (hitting Enter after each command to ‘run’ it)
(also remember Linux commands ARE case sensitive so enter exactly as shown, or even better copy and paste).

First, just in case you already have a newer version of Firefox installed than the version that came pre-installed on your AA1, run the following command to back it up:

sudo mv -v /opt/firefox /opt/firefox-backup

(don’t worry if the above command fails, it just means you don’t have a newer version)

Now use wget to download Firefox 5:

wget -O firefox-5.0.tar.bz2 ""

(you can change the en-GB language variable on the end to any of the other language codes for FF5 that can be found HERE)

Extract the just downloaded file to /opt … create a plugins directory … change the /opt/firefox directory owner … rename the original firefox shell script (just in case you need to start the original firefox from the command line)… and add a symlink to point to Firefox 5:

sudo tar -jxvf firefox-5.0.tar.bz2 --directory /opt


sudo mkdir /opt/firefox/plugins


sudo chown user -R /opt/firefox


sudo mv /usr/bin/firefox /usr/bin/original-firefox


sudo ln -fs /opt/firefox/firefox /usr/bin/firefox

Now, link all old plugins to the new firefox/plugins directory:

sudo ln -s /usr/lib/mozilla/plugins/* /opt/firefox/plugins

Ok that’s Firefox 5 installed, but if you attempt to start it now you will get an error similar to:

[b]firefox/ version `GLIBCXX_3.4.9' not found (required by firefox/[/b]

So next you need to put a copy of in the /opt/firefox directory… Firefox 5 requires this file to be installed on your system but it isn’t available in the linpus lite repos… so use wget to download it from my dropbox:


and unpack it directly into the /opt/firefox directory:

sudo tar -jxvf libstdc++6.tar.bz2 --directory /opt/firefox

Launch Firefox’s profile manager:

firefox -profilemanager -no-remote

Create a new profile… you can name it anything you like… and select it.

As a bonus you can also change the icon to the official Firefox icon. (though this isn’t necessary)

sudo sed '/Icon/ s/acs_//' -i /usr/share/applications/linpus-web.desktop

Finally reboot the AA1 to make the desktop aware of the new icon and browser location.

Most of the credit must go to macles.blogspot:
I’ve just modified the instruction slightly for FF5, and added the file (from fedora 10 32bit) which is needed by FF4 / FF5 / FF6.

For instructions on how to upgrade the flashplayer plugin, see here:

Also see:

Hi Mark,

updating from Firefox 4 to Firefox 5 worked like a charm for my AAO.
Thank your for your continuing support!


You’re welcome, and thanks for the feedback/input :slight_smile:

This is not about Firefox but closely related.

Today, I have not been able to successfully update Thunderbird on my Acer Aspire One. The software performed an auto update from version 3.1.11 to 5.0 but would not start up again. This is very similar to when I first installed Firefox 5 without reading your instructions before :wink:

Probably, a library is also missing here.

If you have any hints, it would be much appreciated!
Thank you!

If you try to open thunderbird from the command line, what is returned ?

I have already re-installed the functioning version (3.1.11). So cannot check this at the moment…sorry.

As I can see from the Thunderbird 5 requirements website
there should be not problem running this version on Linpus, especially after the libstdc++ installation for Firefox 4.

NO… wasn’t installed systemwide… it was only installed to the firefox directory, so only firefox can use it.

if Thunderbird ALSO requires then you’ll have to also place a copy (or symlink) in the thunderbird directory… but you can only do this if Thunderbird was installed to a separate directory of its own rather than systemwide.

How did you install Thunderbird 3 ?


From the system requirements on the mozilla site, it seems you only need libstdc++ 4.3 or higher… so it probably isn’t the same problem… Linpus has libstdc++5 by default (I think)

I’ll see if I can work out what’s missing and if anything can be done about it… but it may take some time… I don’t have an AA1 to test it on, and Linpus refuses to run in a VM

Thank you for your hint…should have seen that from your above post :wink:

I had originally downloaded an archive ( of Thunderbird. Instructions where from

This worked fine (including all updates) until today.

Hmm… you may be right about libstdc++6, as the ONLY requirement that appears to have changed for Thunderbird 5 is the need to have libstdc++4.3 or higher -

Thunderbird 3 requirements here:

Thunderbird 5 requirements here:

So maybe you could test it by downloading Thunderbird 5 to your home directory… unpacking it (in your home directory)… then dropping the libstdc++6 file from here:
into the new thunderbird directory… then running it from the command line with:


and letting me know if it works… if it DOES work, updating Thunderbird 3 should be easy, if it DOESN’T work it may give us a clue why.

as long as you unpack it in your home directory, and run it from there, it shouldn’t interfere with Thunderbird 3 you have in /opt/thunderbird

If it DOES work… I’ll explain how to upgrade Thunderbird 3

Thanks for your detailed suggestions.

It is indeed just the libstdc++6 file again. I have dropped it into the existing thunderbird folder and updating just worked fine.
Hope this helps other AAO users, too.

Thanks geko_03… yet again… for the info. :slight_smile:


Trying to upgrade to Firefox 5. When I execute the “sudo tar …” command you provide, I get “bzip2: (stdin) is not a bzip2 file”. I don’t see why tar think its input is from stdin.

Thanks in advance.

Hi, and welcome to the forum :slight_smile:

I reckon the file you downloaded with wget is corrupt… try downloading it again.

What command did you use to get it ?

stdin = standard input stream

which in this case just means the input file… bzip2 is telling you the file you are trying to input/untar isn’t a standard .bz2 archive, so is probably corrupt.

As the location in your forum profile says US, use this wget command:

wget -O firefox-5.0.tar.bz2 ""

then untar with:

sudo tar -jxvf firefox-5.0.tar.bz2 --directory /opt


Theses instructions don’t work for me! I have firefox 3.6.17 by creating a firefox 2 backup. I followed these instructions and it installed like a dream. However, I can’t download any programmes. I have to go to a different pc and save programmes to usb flash drive and then transfer it to my acer, linux lite running fedora 5 redhat. This is probably not a bad thing. I’ve also done a yum fedora release update and have a new version although I there is no visual difference. However, the check upates on firefox now stays checked, which was refused in 2, but I have a system block to install updates on 3. Even using yum it comes up with block 1866. no idea what that is. yum says I’ve got lib++6 library thing that it told me was missing and it has unpacked the firefox 5.0 tar ball and copy and pasted the ln link command but still no upgrade. I’ve done a yum clean up to keep my system tidy.

The only thing I can think of that was also mentioned was gck I think it was called but there was an issue that yum also installed gck2 which caused problems, so I haven’t done either.

What ever it needs to do, I wish it would just do its thing that it needs to do to be happy and just work.
I’m stuck.
Can you help please?

Hi all

The only instructions that worked for me to install firefox 3.6.17 from 2 was found here

Would like new instructions to upgrade to firefox 4 5 or 6 please as although firefox now tells me that there are updates available, it won’t install them. Yum tells me I have the new lib++6 thing installed which it told me I needed so I got. I have got firefox tar ball 5 and I have unpacked it, but the ln sym link won’t connect firefox 1 2 and 3 to 5. I have an acer, linpus linux lite running fedora redhat 5 and I ran the yum update fedora-release which tells me that I have an upgraded version but visually there is no change. Whether there is a difference between Ther instructions from the abve link saidt to just change the number of firefox to install any version, but that hasn’t worked now.

I wish it would just be happy by quietly doing it’s thing so that it works. That would make me really happy too. I don’t know what it needs to make it happy. It has what it has asked for. I don’t know how to tell it that it has what it asked for and I don’t want to feel like this any more.

Can anyone help me please?

First of all, Linpus Lite, Fedora, and Redhat5 are all different distributions… so there is some confusion about which distro you are using.

Does your desktop look like this ?

If not, you are NOT running Linpus Lite.

That said, with a few modifications, the instructions on this page can be made to work on ANY Linux distro.

If you’ ahev followed instructions at the top of this topic… what happens if you open a terminal and enter:


then hit enter ? … does Firefox 5 open ?

Also can you post your username… you can find this by looking at the prompt line in a terminal, you’re looking for the bit I’ve highlighted in red in the following example - mark@marks-pc:~$

Can you also enter these 3 commands into a terminal:

lsb_release -a


cat /etc/*-release


uname -a

and post the output.


Linpus linux lite. I have the standard desktop. same as yours, or I would not be on here.
my downloads go into the downloads directory not the opt diectory. when running alt+f2 /opt/firefox/firefox says no such directory. that is why these instructions don’t work for me and the link I posted does.

sorry I miss typed. fedora 5 not redhat5. redhat was part of fedora I believe. I am guessing that it seems a number of distributions were put on to the aao zg5 so users could have a choice of which one to use. I also have gnome screen saver and xfce desktop. Following some of the instructions on other forums, my pc threw up a list of everything installed. this gave me the info I gave you. Reg’shardware page I followed to install the bits I wanted. Firefox on his page didn’t work for me either.

when I find out the name bit of info asked for, I will use it. sorry

OK, Open a terminal…

To open a terminal, hit Alt+F2 … in the input field type terminal and click the Run button… a terminal will open.

In the terminal type:

ls -al /opt

hit enter… then post the resulting output back here.

also try entering:


into a terminal (not the Alt+F2 box)… hit enter, and post back the output.

BTW, Linpus Lite (as pictured above) is based on Fedora 8 (not Fedora 5)


Thanks. The revised wget statement worked. I was working from a printout, which was most likely truncated.


No problem :slight_smile: … glad you’re up and running now.