Install Firefox 5 on an Acer Aspire One running Linpus Lite Linux

Thanks for posting the guide to help us losers on linpus lite :cry: I probably wouldn’t care about firefox5 but google+ won’t run without it

I am able to download and unzip etc but when I get to the last part I get this

sudo tar -jxvf libstdc++6.tar.bz2 --directory /opt/firefox
tar: libstdc++6.tar.bz2: Cannot open: No such file or directory
tar: Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error exit delayed from previous errors

I went to the next step
firefox -profilemanager -no-remote
/opt/firefox/firefox-bin: /usr/lib/ version `GLIBCXX_3.4.9’ not found (required by /opt/firefox/

your help is appreciated.

OK, lets try again (but include the path)… open a terminal and enter:

rm -v ~/libstdc++6.tar.bz2

(the above command will fail if the file doesn’t exist… this is expected… just move onto the next command)

then run:

cd ~

then run:

wget -P ~/

expected output should be similar to:

--2011-07-13 01:46:33-- Resolving Connecting to||:80... connected. HTTP request sent, awaiting response... 200 OK Length: 322802 (315K) [application/octet-stream] Saving to: `/home/user/libstdc++6.tar.bz2'

100%[======================================>] 322,802 342K/s in 0.9s

2011-07-13 01:46:35 (342 KB/s) - `/home/user/libstdc++6.tar.bz2’ saved [322802/322802]

wait till that command finishes and leaves you back at a prompt, then run:

sudo tar -jxvf ~/libstdc++6.tar.bz2 --directory /opt/firefox

expected output should be similar to:

Now try running Firefox.

If that doesn’t work, can you send the output from this command entered in a terminal:

ls -l ~/libstdc++6.tar.bz2

The output I’m expecting should be similar to:

-rw-r--r-- 1 user user 322802 2011-07-13 01:31 /home/user/libstdc++6.tar.bz2

All you are trying to do is download this file:
unpack it… and copy/move the file to the /opt/firefox directory.

Hi, thanks again for your help. Two things, do not attempt linpus tampering at 1am and read instructions more carefully :o :wink:

I realised too late that I actually had FF3.something installed and not 2. When I loaded my netbook today the browser wouldn’t operate. I managed to re-install 2 but that didn’t help until I saw the other post on this forum from June about the same problem so I followed the instructions and had 2 running again. I then followed the install 5 to the letter (I think I had skipped the download from dropbox step as you say) and now it all works fine.

Your patience and expertise has been greatly appreciated.

[root@localhost user]# ls -al /opt
total 16
drwxr-xr-x 4 root root 4096 2011-07-13 22:54 .
drwxr-xr-x 25 root root 4096 2011-07-17 13:49 …
drwxr-xr-x 5 root root 4096 2008-06-03 18:29 Adobe
drwxr-xr-x 12 root root 4096 2011-07-13 22:54 GKxdatacard
[root@localhost user]#


[root@localhost user]# /opt/firefox/firefox
bash: /opt/firefox/firefox: No such file or directory
[root@localhost user]#

@ bek456

The above instructions on this page will work for you… I’m going to guess that when the first command failed, you didn’t proceed any further (normally a good idea)… but did you read the bit in brackets underneath the first command ?

(don't worry if the above command fails, it just means you don't have a newer version)

Which (in your case) means… you don’t have a newer version at that location (/opt/firefox).

BUT… if you’d be happier doing it your way, I can PM instructions if you wish… but this way is safer, as it doesn’t mess with your original version of Firefox at all.

It didn’t work. It doesn’t work. It did everything it is meant to do to give the APPEARANCE of working, but IT DOESN’T WORK.

I don’t know why it doesn’t work. I really wish it would work. 6 times I’ve followed these instructions and twice now. copied and pasted each line individually into the terminal so I didn’t get any typing errors etc. I’ve even rebooted the system to give me a clean slate. These last two times I tried it, closed everything, re started.

It doesn’t work. Close to tears.

OK, first don’t panic… you should still be able start your old version of firefox by opening a terminal and entering:


Can you confirm this.

Then look for me in chat, and we’ll go through installing Firefox 5 one step at a time.

now I’m lost.

I’m not using ff2.

the link I posted shows I was able to install ff3.0.17

ff2 is fully backed up since if it wasn’t I’d have lost the desktop. I still have my desktop. it will be known that I’ve backed up ff2 since the link I posted says to. I can’t upgrade to ff4 or ff5 because something in acer is blocking permission. see attached.

macles instructions didn’t work for me either. theses instructions were the only instructions that worked for me.all I need is a code or something that I could type or copy and paste so the updates and/ or new programmes can be accepted by this bleeping laptop without all this agro! It’s drama I really don’t need.

I don’t really need to go back to ff2 since ff3 works, but I can’t move from ff3 and since the auto updates won’t update, there is a bug that keeps turning off my wireless, which I’m hoping upgrading my ff3 to 4 or 5 will sort out

Who mentioned anything about going back to FF2…

You WON’T be going back to FF2… after following your instructions… you now have FF3 at /usr/lib/firefox-

Can you (at the moment) still open FF3 ? … either from your desktop icon, or by:


I’m going to find it hard to help if you don’t answer my questions, or don’t trust that what I’m saying will NOT harm your system.

I FULLY understand what the instructions you followed did, but if I tell you how to get permission to upgrade FF3 to FF5 in its current location… I’ll guarantee you will be left without a working browser at all.

If you want an explanation…

With your instructions, you effectively moved the original copy of your FF2 directory from /usr/lib/firefox- to /usr/lib/firefox- … then created an empty directory at the old location (/usr/lib/firefox- and extracted the FF3 archive into it… so now when you start firefox, it follows the original path and starts the version of firefox that is contained there, which now happens to be FF3 even though it is in a directory called firefox-

Backing up FF2 in this way was NOT what stopped your desktop from screwing up… the ONLY way that would happen is if you REMOVED FF2 altogether through yum… which ALSO uninstalls a load of dependencies which happens to include half your desktop.

If I tell you how to upgrade FF3 in its current location… you will NOT have the necessary extra file ( needed to run FF5, and you will be left without a working browser.

Installing FF5 to /opt/firefox and placing a symlink earlier in the PATH is a MUCH safer way of upgrading to FF5, which will also allow you to start FF2 (or in your case FF3) from the command line if anything goes wrong… and worse case scenario, you’d only have to delete or rename the symlink to immediately go back to being able to start FF2 (FF3 in your case) from your desktop icon.

Now your either going to accept what I’m telling you, or not… but you can see from the comments in the FF5 and FF4 threads that these instructions (barring the AA1 sudo bug or typos) have worked for everyone who has tried them.

I’m quite willing to help you, but you’ll have to decide whether you’re going to listen to me or not, and not try to pre-empt what you think I’m saying :slight_smile:


Big thanks to Mark and macles.

I was having problems with my browser not responding (AAO and FF2 with Linpus Linux Lite v1.0.21.E). After following the instructions for FF5 installation, I now have no more problems.

Thanks again for a very quick fix. I wish I had checked this site 3 weeks ago!

Hi kstkst… and welcome to the forum.

You’re more than welcome :slight_smile: … Thanks for the feedback.

Posted by: Mark Greaves (PCNetSpec)
« on: Today at 06:05:41 pm »

* Insert Quote

Who mentioned anything about going back to FF2…

you did!

Posted by: Mark Greaves (PCNetSpec)
« on: Today at 05:37:51 pm »

* Insert Quote

OK, first don’t panic… you should still be able start your old version of firefox

but thank you for the explanation. I appreciate your time and effort. PM me please, since having a rant on a public forum really is not good manners. My appologies to all.

No I didn’t… I said you would be able to start the version at /usr/lib/firefox- from the command line if necessary.
Which on your machine, happens to be FF3

I’m not arguing with you. merely asking for clarity for my understanding on what you said, since what you said is not clear.

ah. so opening a terminal in the first reply and opening a command line in the second reply must mean the same thing. either way opening up a terminal to start ff2 is not the same as re-instating ff2, which is what I believe you meant when you said to start the old version. Hence my confusion for non clarity. but ff2 can still be accessed if need be by using a terminal to run a command line. Clarity. I understand.

'Backing up FF2 in this way was NOT what stopped your desktop from screwing up. ’

My desktop has never screwed up thankfully. Why you think this, I don’t know. May have me confused with another person.

The rest I understand and agree with. ff2 was backed up. by backing up ff2 moved it from ff2 folder, to a backup folder. This leaves ff2 folder empty but retains its name and merely placing ff3 into ff2 folder.

Ready to proceed when your ready and if you are still willing.

Part of the link I posted means that some instructions do not always work for all.

‘these instructions (barring the AA1 sudo bug or typos) have worked for everyone who has tried them.’ I’m glad that these instrucctins have worked for the majority. Therefore what works for some, there will always be an exception to the rule. Unfortunately, my pc happens to be an exception.

I am all ears and willing to learn and apply any instructions. BUT, I need you to be clear so that I don’t have to question what you mean when two different ways of wording command line and terminal in essence means the same thing.

Moving on how can I fix it please

@ bec456

I would have thought that using the phrase “enter this command in a terminal” in 3 postings, then using the term “command line” in the same context would have been fairly self explanatory, but I would have been happy to clarify if you’d asked rather than ranted.

All I was getting at was that your statement:

ff2 is fully backed up since if it wasn't I'd have lost the desktop. I still have my desktop.

was in fact only half correct… it wasn’t the fact that you’d backed up FF2 that somehow stopped your desktop from being “lost”, it was the fact that you hadn’t uninstalled FF2… I didn’t want any future readers thinking it would be safe to backup FF2, then uninstall it… this would definitely kill their desktop… it’s the act of uninstalling FF2 that kills the desktop.

You stated in your first post:

yum says I've got lib++6 library thing that it told me was missing and it has unpacked the firefox 5.0 tar ball and copy and pasted the ln link command but still no upgrade

nowhere in my instructions is the use of yum to install anything mentioned, and if done correctly yum will be completely unaware of the FF5 and installation.

I still stand by my statement that if entered correctly, and barring the Linpus Lite sudo bug, these instructions will work for EVERYONE… including your AA1.


I take it you’ve followed my instructions for FF5 pretty much to completion… can you answer these questions, so I can find out how much got installed.

At the moment, are you able to open FF3 from the desktop icon, or are you having to enter a command in the terminal ?

Open a terminal and enter:

ls -l /opt

and post the output (what is returned in the terminal after running the command)

then enter:

ls -l /opt/firefox/

and post the output.

then enter:

ls -l /usr/bin/firefox

and post the output

then enter:

echo $PATH

and post the output

Remember, Linux commands ARE case sensitive, so enter them exactly as shown… probably best to copy/paste and also visually verify the command before hitting enter.

I don’t understand how Mark could have been anymore “clearer” than what he is posting. Clearly, if you hadn’t used another set of instructions we may have not ended up here, because as far as I’m aware, these instructions are down to a tea. This is why we tell people to read, and re-read instruction to ensure situations like this are eliminated.

BkS I’m glad they worked for you. the other instructions worked for me. credit to mm2004 for those instructions!

Mark. ‘nowhere in my instructions is the use of yum to install anything.’ I know you didn’t. I used yum to CHECK what had been installed.yum says as quoted. I didn’t use yum to actually install anything connected with firefox because of the info in macles blog states it drags loads of info with it. please don’t assume or 'try to pre-empt what you think I’m saying :slight_smile:

Credit to Macles blog says not to uninstall ff2, so I never have. I created a backup instead so if there were problems I could revert to ff2 should it have become necessary.

[root@localhost user]# ls -l /opt
total 12
drwxr-xr-x 5 root root 4096 2008-06-03 18:29 Adobe
drwxr-xr-x 8 root root 4096 2011-06-16 00:04 firefox
drwxr-xr-x 12 root root 4096 2011-07-13 22:54 GKxdatacard
[root@localhost user]# ls -l /opt/firefox/
ls: cannot access /opt/firefox/ No such file or directory
[root@localhost user]# ls -l /usr/bin/firefox
-rwxr-xr-x 1 root root 6108 2008-06-12 09:35 /usr/bin/firefox
[root@localhost user]# echo $PATH
[root@localhost user]#

I can open ff3 from my desk top and from a terminal. I have never not been able to following mm2004 instructions to upgrade ff2 to ff3. It was unfortunately following Macles instructions to install ff3, I lost desktop use to access the net and terminal use to access the net. losing desktop does not mean I didn’t have a desktop at all; it merely means that clicking on the browser icon on the desktop, I got the spinny thing but nothing else.

I do understand what you said, it just doesn’t make sense… you obviously don’t understand the Yellowdog Updater Modified’s job… YUM will NOT be able to track the installation of FF5 or libstdc++6 as it ONLY tracks “package” installation… neither of these are being installed as “packages”.

Sorry, I made a typo in one of the “list” commands…

What is the output from:

ls -l /opt/firefox/

One other thing… are you logged on as root ? … or are you changing to root in the terminal ?

If unsure… when you first open a terminal, before you enter anything, does your prompt look like this:
[root@localhost user]#

or is it something else that ends with an $
similar to:
[user@localhost user]$

[root@localhost user]# ls -l /opt/firfox/
ls: cannot access /opt/firfox/ No such file or directory
[root@localhost user]#

[user@localhost ~]$

oh come on mark, it says root at the beginning. you only get to root after typing the password so Macles said.

you also know I don’t have an /opt/firefox directory. since you said so wryly yourself.

what is is you really need to be able to help me since I just feel you are trying to wind me up. I’m annoyed witth this pc not doing what you tell me it should do when I follow your instructions. Will you please stop giving me a hard time. I’m annoyed with it, not you since I appreciate you are trying to help me.

yellowdog updater has not shown it’s face to me so, yes I don’t know what it is. quite frankly I’m beyond caring right now. I just want to get this sorted.
what do you need next to see if you can get my pc to work the way you think it should?

one difference I have noticed is some have their names in whare it says user.

I’ve already explained WHY I needed you to answer a few questions:

You’ve followed the instructions at the top of this topic since I last said you had no /opt/firefox directory… your last response:

Says you now DO have an /opt/firefox directory

d = directory, so you DO (now) have a directory called firefox at /opt

I was trying to find out if you’d managed to put in that directory yet.

I’m sorry, but I cannot… no I refuse to help you, when you question everything I ask in an amazingly arrogant manner for someone that is asking for help.

I suggest you go off and learn the Linux command line, as with your attitude you will find help hard to come by on forums.

do a bit of research before jumping to conclusions… you can get to a root prompt many ways, one of which is by logging on as root… so it was a perfectly reasonable question that would have had a bearing on ownership of the /opt/firefox directory.

I already know what is stopping macles and my instructions working for you… and if you’d just answered the (necessary) questions without the attitude, it would be fixed by now.