Installation problems

Hey, I am currently a Windows user trying to install Ubuntu on my computer; however, every time I try the screen glitches up displaying random lines of colour on the screen during the installation process and splitting the screen in half once it is installed, rendering it unusable. The unit I’m using is an Advent DT1411 and I’d just like to know if there are any known compatibility issues with this and if there is anything I can do to fix this, or another distro I could use instead. Thanks in advance.

Would I be right in saying the Advent Advent DT1411 has a Core i5 2320 (Sandy Bridge) CPU ?

Has it got an ATI Radeon HD6700M (add in) graphics card ? … as well as a graphics adapter built into the motherboard (onboard) ?

If so, have you tried the onboard card ?

You are correct in everything you just said, but honestly, I have no idea how I would go about doing it. I don’t really know too much about computers, but I’m doing my best to learn, so please excuse my ignorance.

From a quick search the problem seems to be related to the Sandy Bridge CPU containing an integrated graphics adapter (on-chip) that doesn’t seem to be correctly switched off when an add-in graphics card is also present.

From what I’m reading there seems to be be a way round the problem, but I want to do some more homework on the issue before suggesting anything … can you check back tomorrow night(ish), and I’ll see what I can come up with :slight_smile:

Wow, thank you very much, you have been incredibly kind

Can you answer me a question … when you boot to an Ubuntu LiveCD, and select “Try Ubuntu”, do you end up at a working desktop, or are your graphics still messed up ?

I have no idea, sorry, I’m doing my best to find out for you now, I’ll let you know ASAP

If you need help or have any questions … just ask :slight_smile:

Ok, just got it working there now. It works fine, but the colours are still very glitchy; it is usable however.

OK, great … can you hit Ctrl+Alt+T (at the same time) … a terminal should open, in the terminal type:

sudo lshw -C display

and hit the enter key.

give the command a few seconds to finish, and post back what the output was.

be aware Linux commands ARE case sensitive, so that’s a capital C :slight_smile:

for clarity that’s…
sudo lshw -C display

I’m not entirely sure which bit you want so I’ll just post the whole thing:
“ubuntu@ubuntu:~$ sudo lshw -C display
description: VGA compatible controller
product: Turks XT [AMD Radeon HD 6600 Series]
vendor: ATI Technologies Inc
physical id: 0
bus info: pci@0000:01:00.0
version: 00
width: 64 bits
clock: 33MHz
capabilities: pm pciexpress msi vga_controller bus_master cap_list rom
configuration: driver=radeon latency=0
resources: irq:44 memory:d0000000-dfffffff memory:fe620000-fe63ffff ioport:e000(size=256) memory:fe600000-fe61ffff”

If you open a terminal and enter:


is anything listed under additional drivers ?

BTW, if there are any … there’s no point trying to activate them from the LiveCD … I just want to know if there is anything listed.

No, nothing comes up

Do you have a USB stick larger than 1GB and do you know how to create a LiveUSB stick with persisence ?

I want to try installing the fglrx drivers, but this can’t be done on a LiveCD … and I’d rather not try it on your hard drive installation till it’s tested first.

I am actually using the LiveUSB at the moment, but I have no idea what you mean by the second bit

How did you create the LiveUSB stick ? … ie. which application did you use ?

lets find out if your LiveUSB has persistence …

right-click on the desktop and select Create New Document > Empty Document … if you can now see a document on the desktop, REBOOT to the LiveUSB again.

if the document is still there after the reboot, you have “persistence” on the LiveUSB and we can attempt the installation of the FGLRX driver

I used the USB Installer off, just because it was recommended by the Ubuntu website. Also, I’ve run into a slight problem where if I want to boot it and have it working, I have to select the option to search for defective files first, so I don’t know if this would wipe my files or what, but either way my files aren’t there after the boot.
By the way, I don’t know if this affects anything, but I am trying to dual-boot with Windows 7, just in case that makes a difference.

OK we need to get a few things straigh before we proceed

  1. When you say “alongside Windows” do you mean you resized the Windows partition and installed Ubuntu into its own partition ? … or do you mean “inside Windows” by using the WUBI installer ?
    if unsure, boot into windows and see if there is a folder called ubuntu on your [b]C:[/b] drive (C:\ubuntu)

  2. When you say:- “if I want to boot it and have it working, I have to select the option to search for defective files first”
    Do you mean when booting the LiveUSB or the hard drive … if you mean the LiveUSB, can you explain the procedure you have to go through (step by step) to get it to boot.

By the way, I don't know if this affects anything, but I am trying to dual-boot with Windows 7, just in case that makes a difference.

Nope, this is just a graphics driver issue … we need to install the proprietary ATI (fglrx) driver instead of the open source radeon driver.

jockey should be detecting the card and offering you the correct driver, but for some reason isn’t … so we’ll have to install it manually, but I’d rather test this first on a LiveUSB with persistence.

See here for instructions on using Universal USB Installer to create a LiveUSB with persistence:
see the part about creating the LiveUSB, but obviously change the distribution from Peppermint to Ubuntu 11.10

Well I’m currently trying to install it inside Windows, but my drive is already partitioned from a previous attempt, so I don’t mind doing that if it’s a problem.
When I boot up a computer a black screen appears giving me three options, I’m not sure what the middle one is, but the first option is to run Ubuntu and the third is to Check for defective files, and if I select the first one, the screen glitches out and nothing works, so I need to select the third option to check for defective files, then the computer reboots and I can select the first option.
Lastly, I’m working my way through that now, I hadn’t assigned any memory to persistence the first time I did it.

Ok, now that I’ve done that it’s not working at all, it either reboots or sends me onto a black screen with white writing and a glitchy colours in the background playing the first few seconds of the starting music in a loop…