Installing peppermint on an old Compaq deskpro

Hi Guys

I’m trying to install peppermint on an old Compaq deskpro (currently running windows XP) but I cant get it to display the live session it gets as far as the options menu (run live session, install etc) but when I click run live session I then just a blank screen. I’ve tried with a peppermint disc and a Zorin disc but it’s just the same

I feel this is some kind of graphics problem but no idea what to do next.

I tried another ROM Drive but when I reboot I just a command prompt saying “vesamenu.c32: not a COM32 image” the underneath “Boot”, it keeps scrolling that over and over

Also when I change drives a post boot message says " if you are running unix, you have to configure your system using the computer setup utility (F10), but I have no idea what to configure

Any help would be much appreciated

Many thanks


Go back to your original drive … boot to it, and as soon as you see the Peppermint “options menu”, hit the Tab key …

You will now see some writing at the bottom of the screen that ends with:-

initrd.lz quiet splash –
(and a flashing cursor)

Use the Backspace key to replace quiet splash – with nomodeset… so it now just ends with:-

initrd.lz quiet splash nomodeset

Now hit Enter to boot.

Does it boot now ?

If not … what is displayed ?

If I’m understanding correctly, the other drive is having problems with the LiveCD’s menu structure … when it leaves you at:-


Try typing:-


and hitting the Enter key.

If not .. what is displayed ?

I did as you said I’m now getting a white scree with black blocks and white writing ending with a command prompt

Have you got the exact model of DeskPro, so I can check the specs.

it’s a Deskpro EN pentium 3 800mhz

I tried plugging in the other drive and typing “live at “boot” it stops with uncompression error” then underneath “–system halted”

Any idea how much RAM ? (may say in the BIOS or be displayed during POST)

There’s 512mb which is as much as it can take

Run Memtest86 on the RAM to make sure there’s no errors … otherwise I think this must be an issue with either the CD or the CD drive.

Did you burn the ISO to CD or DVD ? … oddly I’ve found older drives tend to get on better with DVDR’s than CDR’s

Have you tested the CD in another PC ?

ok I run memtest and no errors reported, I don;t think it the disc because I’ve tried 4 different discs one Peppermint, one Zorin and one Lubuntu and none of them will load with any of the 2 CD drives I have but if I have some other drives at home I could try tomorrow


There may be more than 1 issue here

one with the second drive
(uncompression error … normally means bad disk/drive/memory


one with the PC and compatibility.
(screwy graphics)

It would be handy to know for sure if the burned disks boot in another PC … just to rule out the CD/DVD

Then we’ll move on to trying to copy the disks contents in Windows … if it can read the disk to copy … theree’s nowt wrong with the drive.

Then we can move on to hardware compatibility

ok I’ll test the discs tonight to see if they boot in my home PC

This is an old PC one of my employees ask me for it when I replaced it recently but it has Win XP installed I replaced it because it was getting deathly slow so I thought it would run ok with peppermint or maybe Zorin for her because she only wants to get on Facebook and email basically, but it maybe a lost cause

Thanks for your help so far


I would suggest to try Wary Puppy (for older hardware) just to see if it is doable and what drivers etc it uses.

I would suggest to try Wary Puppy (for older hardware) just to see if it is doable and what drivers etc it uses.

Never heard of it but I’ll have a look thanks

I opted for Peppermint because I thought it would be lightweight enough for all she wants to do with it and as i use Peppermint myself I would be more able to help her if she had problems.

I think Peppermint would be perfect for her if it was set up right but I’m also toying with Zorin, what do you think ?

i hoping this is just a CD/CD Drive problem as i have a few spare drives I could try.

Another option I though of was installing on a different machine and transferring the drive over but that’s a bit of a pain and shouldn’t be necessary

Many thanks


I personally think that any distros based on Ubuntu will be too new for that machine.
The stumbling block may be the amount of ram and the graphics/chipset drivers.
As an alternative you could try Debian with LXDE with a few minor tweaks you could get it set up just like Peppermint.

Sorry, I’ve been a bit busy today …

You wouldn’t happen to have another graphics card you could try ?


Seems the DeskPro EN’s were sold with 3 different graphics cards

Graphics – One of the following: Matrox Millennium G400-SG AGP Graphics Controller with 16-MB SGRAM standard, not upgradable, providing maximum resolution of 2048 x 1536 x 16.7M colors at 65 Hz

ATI RAGE PRO TURBO AGP 2X Graphics Controller card with 8-MB SDRAM standard not upgradable, providing maximum resolution of 1280 x 1024 x 16.7M colors at 85 Hz

Integrated Intel 3D Graphics featuring Intel Dynamic Video Memory (DVM) technology with 8-MB video memory equivalent performance, providing maximum resolution of 1280 x 1024 with 16.7M colors 85 Hz

So you might want to try




in place of the “nomodeset” in my earlier reply … you could also leave out the “quiet splash” and see if it gives any clues where the boot is failing.


Thank you Mark,

I’ll have a look when i get to work

You wouldn't happen to have another graphics card you could try ?

I have a few spare cards but I’m pretty sure there is no AGP slot on that machine but I’ll check it out when I get to work, I remember a while ago I run a Peppermint 2 live session on that machine without a problem and that was at a time when it only had 256MB of RAM ( I upgraded to 512MB since then) which is the maximum for that PC, so I’m pretty sure Peppermint can run on that machine unless they’ve change something about graphics compatibility in Peppermint 3.

I’ve got some ROM drives I’ll try (2CD’s 1DVD) and I’m burning a fresh copy of Peppermint which I’ll test on this machine to eliminate any doubt about the installation media.

So I have a few things I can try, I’ll let you know how it goes.

Many thanks


Not sure iuf this puts a different light on things but I tried another DVD/CD ROM drive but it’s still the same but I haven’t tried the commands Mark suggested, however I had an oldish Slitaz disc and it booted up into the live session no problem, I’m noit really to keen to go ahead and install, but thought I’d ask for an opinion before I go any further

Many thanks


If it’s an old Slitaz, it’ll probably have old graphics drivers (or possibly non, so would default to vesa … which is what xforcevesa should do) … so try the kernel boot options I suggested

Ok I finally got peppermint installed,long story but the problem appeared to be the wireless network card, it indicated that when I run the disc with “quiet splash” removed as it always halted at “starting network” or “configuring network” so I removed the wireless card and it booted straight away.

I don’t think there’s anything wrong with the card itself as it was working in Windows probably some compatibility issue I don’t know but anyhow it working fine.

Big thanks once again for your help


Is it a broadcom chip ?