Internet Connection Sharing - Support Question

Currently installing the Beta 2 version of Ubuntu Server 12.04. I haven’t managed to get my 5-port switch yet, so the NAS ain’t got network access. However it sits right next to my laptop, so I’ve tried sharing a wired connecting between the two through ICS by switching the IPv4 settings to “Share with other computers”. No luck unfortunately. Works with the X360 quite fine though.

Help please?

First of all (as the server edition has no nice friendly GUI) read this:

ignore vi as the editor (unless you know it), use nano instead.

First you need to see if the network interface is working:

sudo lshw -C network



and check the contents of

nano /etc/network/interfaces

IIRC, the “client” (eg. your server box) in an ICS setup needs to be configured to get its address through DHCP … is my memory correct ?

From what I can see, through ICS it’s not getting to the gateway. It detects the connection coming from the laptop, just won’t pass through it. Limme go run the commands and I’ll return with some outputs.

Yeah it’s needs DHCP IIRC.

You haven’t disabled DHCP in the router have you ?

No, I haven’t. It’s still functional. I reserved addresses .0.2 - .0.100 on the pool though.

Have you tried to set your NAS up with fixed IP address (same subnet as your laptop)?
also is your laptop firewall activated by any chance?
As for not having the GUI on the server that should not be a problem
as you could install Webmin (which I find invaluable)
then access it via your laptops browser

description: Ethernet interface
product: RTL-8139/8139C/8139C+
vendor: Realtek Semiconductor Co., Ltd.
physical id: 2
bus info: pci@0000:02.02.0
logical name: eth0
version: 10
serial: 00:16:76:80:13:b5s
size: 100MB/s
capacity: 100MB/s
width: 32 bits
clock: 33Mhz
capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=full latency=64 link=yes malatency=64 mingnt=32 module=8139too multicast=yes port=MII speed=100MB/s

*-network DISABLED
description: Ethernet interface
physical id: 1
logical name: pan0
serial: aa:f9:de:3d:cb:d9
capabilities: ethernet physical
configuration: broadcast=yes driver=bridge driverversion=2.3 fireware=N/A link=yes multicast=yes

``` ifconfig ```

eth0 Link encap: Ethernet HWaddr 00:16:76:80:13:b5
inet6 addr: fe80::21:76ff:fe80:13b5/64 Scope:Link
RX packets: 0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:1836 (1.8 KB)
Interrupt: 21 Based address:0x1000

lo Link encap: Local Loopbacl
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX bytes: 240 (240.0 B) TX bytes: 240 (240.0 B)

``` nano /etc/network/interfaces ```

auto lo
iface lo inet loopback

I should point out at this time, that I’m running the NAS on Ubuntu 9.10 just now, as I don’t have a P/S2 keyboard to select “English” when the Ubuntu Server disc starts up, and there’s no count-down timer on it either to automatically select that otherwise I’d have been able too.

I also can’t access the BIOS with a P/S2 keyboard either which is crap. :expressionless:

Quick question … you have rebooted the laptop since changing the eth0 to “shared to ther computers” haven’t you ?


Try setting IPv6 to ignore at both end of the ICS connection

and as SeZo suggests … try turning off the firewall if it’s active.

You can check if it’s active with

sudo ufw ststus

turn it off with

sudo ufw disable

turn it on with

sudo ufw enable

Firewall was disabled, and IPv6 was on “Ignore” by default on both. :-/


I don’t know what else to tell you on this as I don’t use ICS, nor have I got a Karmic PC … it might however be a good idea to check if the ethernet card works at all (though the output suggests it does) by plugging it directly into the router and seeing if you get a connection.

or, you could ignore the GUI method, and move straight on to the CLI method, which is documented here:

but you’d still want to verify the network card works first … otherwise you could be wasting your time.

Meanwhile, I’ll keep scouring the interweb … and if I come across anything (though there seems to be a distinct lack), I’ll let you know.

I am however a bit baffled that ifconfig seems to show you getting an IPv6 address (but no IPv4), even though you say IPv6 was set to ignore … I seem to vaguely remember that doesn’t “disable” IPv6, just as the name suggests “ignores” it.

My point is, that with no cable attached, my network card has NEITHER, so something is getting through for it to be assigned an IPv6 address … ie. the system knows it’s attached to something, so I’d guess the issue is at the laptop end, but you still need to verify the card in the box just to rule it out.

Yep, network card works. ICS is a funny bugger init? I’ll give the CLI commands a go, see if it makes any difference.

My initial plan was to use the “Upgrade” option on the disc when you inserted into the drive when in Ubuntu. But I clicked it a few times and nothing seemed to work. So I’ll probs have to go and buy a P/S2 keyboard adapter / a keyboard itself.

With older systems, a PS/2 keyboard is always handy … as there may be no way to access the BIOS, or enter anything until the USB drivers are loaded by the OS otherwise … as you’ve obviously discovered.

Older MoBo’s can’t initialise USB KB’s/Mice on their own.

Depending on the age of the MoBo, there may be an option to turn on support for USB K/B’s and Mice in the BIOS … but you’d still need a PS/2 K/B to do that ??? … and if you ever reset the BIOS, or the battery dies, you’d need the PS/2 K/B again, because it would default to disabled … I never quite understood why the manufacturers did that :o

For a while (IIRC) Dell were selling systems with USB Keyboards and Mice, that if you reset or updated the BIOS (or the battery died) defaulted to having the USB support switched off.

Yeah, I’ll try pick up a P/S2 keyboard or even the adapter. I need to pick up another pack of CDs too as I’m out. (:o) Also need to find some sort of cable/adapter that is USB > 3.5mm female jack. I was shocked when I seen that Maplin, Curry’s, Dixon’s and PC World don’t sell them. ??? Major electronic stores and they don’t even sell such a thing how weird.

Yeh, the one thing Tandy/Radio Shack were good for (odd little connectors and stuff) … before they all disappeared, or are you too young to remember them ?

I remember Radio Shack. Never heard of Tandy sadly.

T’was the same (US) company … they just changed their name.


Ah, I see. If only I had a soldering iron. I’d make the bloody adapter myself, haha.