Linux for an old Dell XPS 210

Can anyone recommend a version of Linux suitable for an old Dell XPS 210? And point me to the installation instructions.



My advice would be to give Peppermint 3 a go … Peppermint is a very “light” distro, and well suited to older hardware … yet is fully featured and has access to all the Ubuntu software.

By default it’s a bit too “cloud” oriented, but there’s nothing to stop you installing “local” applications (some of which are included in the tutorial linked below)

Do stages 1 - 7 (inclusive) here:

Great. Thanks.

Damn Mark beat me there. Good suggestion :slight_smile:

Thanks to you too, gearhead.

I’m a bit stuck on STAGE 3 - Entering your wireless network.

I’m not getting a list of available networks from the NETWORK MANAGER icon. Which is strange because I did earlier and managed to connect wirelessly during stage 2.

I normally have to turn the router off and on again for the computer to see it (which I’ve done again) but still all I get is the option to CONFIGURE VPN which shows my router in the WIRELESS tab - with the option to ADD, EDIT, or DELETE.
I can click EDIT and add my password and SAVE the details, but the wireless connections still don’t show themselves.



What wireless interface are you using? (i.e. built in, USB, etc…) and what model?

Some Wireless interfaces either need a small change or require a full re-install as the module for wireless interfaces has not loaded correctly.

USB, it says

Belkin 882.11g 54Mbps.

I have another one somewhere: D-Link Wireless N. I could try installing that. What do you think?



Can you connect to your router with an ethernet cable … then open a terminal (Ctrl+Alt+T) and send the output from these comands:

sudo lshw -C network






iwlist wlan0 scanning


rfkill list



Be aware … the first command will prompt for your password, but when you enter it nothing will be echoed to screen (not even ******) but it IS going in, so just type it and hit enter.

Also be aware Linux commands ARE case sensitive … so that’s a capital C in the first command.

You can copy/paste the above commands into the terminal if you wish.

Then copy/paste the output back here.

You can certainly try the D-Link if you wish … depending on the model it may just work :slight_smile:

Thanks Mark and Gearhead,

Getting to the router with an ethernet cable is a real pain (I must fix that set-up) … but I replaced the Belkin with the D-Link and hey presto - it works.

I’ll press on to stage 4.

Thanks for all the help.

While I’m asking, is there any chance I’ll get World of Warcraft to work on this? I don’t know much about it, but my step-son plays.


Great … that was a bit of luck :slight_smile:


I’m up to stage 6, and I entered the long command.

The reply says:
Reading package lists … Done
Building dependency tree
Reading stare info … Done
E: Unable to locate package skype

And then waits for another command.

Is this right?



have you tried the software manager? it allows you to download applications using a nice user interface rather than using the command line.


OK - looks good. Do you think I can carry on from here then, using the SOFTWARE MANAGER rather than the stages? Mind you, I can’t seem to fins SKYPE. Do you know which CATEGORY it is in?



Ah apologies, I forget that skype is not in the software manager,

Using this link: Download Skype for mobile & desktop | Skype

select the Debian package (32 bit or 64 bit dependent on the variant you are using, I imagine 32)

This downloads what is called a debian package. I’m not sure how familiar you are with this so I will give a rapid explanation.

Debian packages perform all the command line functions but with a simple click of your mouse. It will use the debian package installer which is found in all debian based Operating Systems.

Hope this helps :slight_smile:

Great. I’ll give that a go.

The other problem I’m having is no audio. Any ideas on that?

Thanks again.


This can happen on some laptops. Lets begin by trying:

sudo apt-get install pulseaudio pavucontrol

Then reboot

This typically has a 50% chance of working.

Now what I am going to do is copy a comment by Mark Greaves that he has left on the peppermint official forums:

is the sound card listed by:

lspci -vnn


sudo lshw -C multimedia


aplay -l


If not, can you run:

dmeshg >> ~/dmesg.txt

You’ll then find a file in your Home folder called dmesg.txt.

Post it’s contents on paterbin HERE
and provide a link to it in your next posting

also where it says here I mean:


Shall I run these commands in TERMINAL from ACCESSORIES?

Terminal if you would be so kind, you should be able to copy their results into the forum or if they are long then use that way you wont take up too much space on the linux forum and keep the forum costs down :slight_smile: