Lost Photo images after upgradeing[fixed]

I’ve just upgraded form ubuntu 10.10 to 11.04 and lost photos(from websites) and bookmarks, I think I might find bookmarks later but the photos are different may be the bookmarks are just in a different place? can you help please, it told me, I had errors and had to install apt, dpkg, peal-base, phython-apt, phython-apt-common, t2data how do I do this?

Hmm… you ran an OS upgrade without (at least) taking a backup of things you couldn’t afford to loose ?

If I were you, I’d boot to a LiveCD, recover your files to an external drive, then reinstall Ubuntu 11.04 as a fresh install from the LiveCD.

Alternatively, you’ll probably have to chroot from a LiveCD to install the missing packages.

Can you boot to a desktop ?

Does Synaptic work ?

I’m not sure how to do any of that ? I cant see synaptic all I have is the tool bar on the side when I said lost photos I meant feeds from a website its was telling me I need x-flash sorry

OK, try booting to an 11.04 LiveCD and running the following commands in sequence from a terminal:

sudo mkdir /mnt/natty
sudo mount /dev/sda1 /mnt/natty
sudo mount -t proc none /mnt/natty/proc
sudo chroot /mnt/natty
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install --reinstall apt dpkg perl-base python-apt python-apt-common tzdata

Of course if your normal HDD Ubuntu partition is anything other than /dev/sda1 that part of the second command will need adjusting.

You’ll also need an active internet connection from the LiveCD.

Be Aware - As you are apparently missing apt and dpkg, there is no guarantee here, it could make matters worse… so make sure you have backed up your user docs, and are ready to do a complete reinstall if necessary.

but how do I get out of the Live cd?

sudo umount /mnt/natty/proc
sudo umount /mnt/natty

close the terminal and reboot to the hard drive.

@ demie17

I’ve split your request for help into its own topic, as it wasn’t really pertinent to this topic:

Ive moved it here:

I’m trying to get the above when you advised me to boot from a live cd with the following but I cant get out to execute these commands

sudo mkdir /mnt/natty
sudo mount /dev/sda1 /mnt/natty
sudo mount -t proc none /mnt/natty/proc
sudo chroot /mnt/natty
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install --reinstall apt dpkg perl-base python-apt python-apt-common tzdata

Please help??? I’m using ubuntu 11.04

Topics merged at this point

Can you please stick to one thread, or this won’t make sense to others… it also helps to be able to review what’s already been said.

What do you mean by:

I cant get out to execute these commands

get out of what ?

I don’t understand where you are having a problem…

Boot to an 11.04 LiveCD, and select “Try Ubuntu” … when you are at the desktop, make sure you have an active internet connection…

Now as long as your Ubuntu installation is on /dev/sda1
(if you’re not sure, let me know)

Open a terminal and enter these commands one line at a time

sudo mkdir /mnt/natty
sudo mount /dev/sda1 /mnt/natty
sudo mount -t proc none /mnt/natty/proc
sudo chroot /mnt/natty
sudo apt-get update
sudo apt-get upgrade
sudo apt-get dist-upgrade
sudo apt-get install --reinstall apt dpkg perl-base python-apt python-apt-common tzdata

when those are finished, run:

sudo umount /mnt/natty/proc
sudo umount /mnt/natty

Now shut down the PC… remove the LiveCD from your CD/DVD drive… and restart the PC.

when I boot from a live CD I get 2 menu’s


[ol]- Boot form Hard drive

  • Boot fedora live
  • Boot fedora live basic video
  • linux mint
  • boot open suse
  • ubuntu 11.04
  • memtest86+[/ol]

second if i select ubuntu

[ol]- try ubuntu without installing

  • install ubuntu
  • check disk for defects
  • test memory
  • boot from the first hard disk
  • main menu[/ol]

then it takes me to the install screen if i press escape here it returns errors but continues to a grafic screen with no terminal
I’ve solved the video/photos bye installing flash but no sound in any media

At the first screen, select:-
6. ubuntu 11.04

At the second screen, select:-

  1. try ubuntu without installing

If that doesn’t get you to a working desktop… there is something wrong with the way the coverdisk was put together… try downloading and burning a “proper” LiveCD ISO image directly from Ubuntu, and burning it to CD/DVD.

Is sound the ONLY issue now ?

Does Synaptic work properly ? … how did you install flash ?

First I tried your instructions via screen 1 & screen 2
I’ve got 3 different dvds of 11.04,

  • this months
    • last months
    • burned version from ubuntu
      I must be missing something there never have terminal option or take me to a prompt
      sound apart from the not installed previous mentioned errors is the only effect I know of
      I installed flash from a website were it give me the option of a version for linux cant remember what the site was now

Do ANY of your DVD’s take you to a working desktop when you select “Try Ubuntu without installing” ?

All you’re supposed to be doing is booting to the LiveCD, selecting “Try Ubuntu”… and when you get to a desktop…

open a terminal, and enter those commands.

Don’t you know how to open a terminal ? … just hit Ctrl+Alt+T (at the same time) … a terminal should open.

still no sound
I got the error “coudn’t configure pre depend for perl-base, probably a dependency cycle”, there was also an error just after it finished installing the office package but I did’nt get it, is this dependent ?

Does Synaptic work now ?

can’t find it but been missing for a while don’t think its same problem

What happens if you open a terminal and enter:

sudo apt-get update && sudo apt-get upgrade

then hit enter, and your password.

Here’s the problem…

We can TRY towork on your sound issue if you want, but I think you still have bigger problems than that… originally one of your postings said apt and dpkg weren’t installed, well apt and dpkg are what the system uses for package management, so without them you will not be able to install anything.

I think you need to sort those issues out before the sound drivers… but the choice is yours.

yes I agree
I try your latest advice looked like it was installing and fixing it all but returned the following

dpkg: unrecoverable fatal error, aborting:
unable to flush /var/lib/dpkg/updates/tmp.i after padding: No space left on device

I tryed the previous commands with returned error

chroot: failed to run command bin/bash no such fie or directory

No I don’t want you to boot to the LiveCD…

Just boot without the CD and run:

sudo apt-get update && sudo apt-get upgrade

and tell me what happens.