No Gnome

Last week there was a flush of updates which were largely KDE related although the Desktop Environment is Gnome. The next morning Gnome only got as far as a blank purple screen will not go any further. The network is operational so the three of us that work from home can still access our files, but the Ubuntu is my working machine so I am have to settle for Windows 7 at present.

I have tried various things suggested on the Ubuntu Forums, but that seems to have come to dead end.

Ubuntu 12.04 is being used.

Thank you.

Do you know how to remove “quiet splash” from the kernel boot line for a single boot, so we can maybe get a clue where the boot is stalling ?

Thank you Mark for your reply.

I am afraid that ‘quiet splash’ is a new one on me.

Thank you.

Turn on your PC, and when you see this GRUB menu:-

Select the ‘default’ kernel (the top one), and rather than pressing enter, press E to edit.

You will be presented with a screen SIMILAR to this:

Press DOWN ARROW until you get to the line that starts with:

linux /boot

and press the END key to position the cursor at the end of the that line… it usually ends with “quiet splash”.

Now use the backspace key to remove the words “quiet splash”
(if present, also remove the “$vt_handoff” parameter)

Now hit Ctrl+X to boot.

It should now display what’s happening during the boot process … does it give any clues where the boot is stalling ?
(eg… any errors, or the last text that’s displayed before it stalls)

Thank you for your reply. I will work through your suggestion and come back to you, however, we are off to Three Counties Show and I may not be able to do this until after the weekend.

No problem … whenever you’re ready :slight_smile:

Right, I have tried that and I get a blank screen with a flashing screen, no text at all. The network still works though.

Are you saying you can access files in the on the Ubuntu box by logging in remotely ?

What happens if (on the Ubuntu box) you hit Ctrl+Alt+F1 … are you presented with a console (text) asking you to log in ?

Yes to both questions. Being able to log on from the 5 Windows boxes we have has eased the problem.

Thank you.

If I understand you right, you are saying that Ubuntu auto logs you in and successfully boot to the desktop
but you cannot see anything because the display is missing.
Is this a laptop or desktop?
Have you tried to connect an external monitor?
It might be down to corrupted configuration files for your desktop.
You could try to boot to a LiveCD and rename your home folder. This will force Ubuntu to re-create your user folder and configurations.
If you can get to a proper desktop after this then you may be able to hunt down the offending configuration file in your old home folder.
Note you can always revert the changes by deleting the newly created user folder and reinstating your old one.

What happens (what is returned) if you run:

sudo service lightdm restart



after logging on in the console ?

Also, do any errors jump out at you if you run:

cat ~/.xsession-errors | less

after logging on in the console ?

BTW, hit “Q” to exit back to a normal prompt.

Might also be a good idea whilst in the console to run:

sudo touch /forcefsck

then reboot with:

sudo shutdown -r now

This should force a file system check on the next boot.

Thank you very much for your comprehensive replies.

The log in is fine, but it stops at the purple screen with no Ubuntu logo appearing.

The machine is a desktop built by us, but we have built or modified hundreds for local businesses. Not so much now that I am retired.

I use TeamView quite a lot, but I cannot get the Ubuntu TeamView password to log on that way.

I will come back to this on Sunday now.

Can you log in remotely with teamviewer to the Ubuntu box at the moment … if so, does it display the desktop ?

TeamView will not connect, it does not even get as far as asking for the remote password.

How are you able to get at the files remotely … ssh ?

Hello, sorry for the delay -busy weekend.

The access to the files is through the normal mapped drives on Windows and Samba on Ubuntu. The only thing I do not get is the Ubuntu Gnome desktop.


sudo service lightdm restart

results in a blank screen apart from a flashing cursor.



causes an error statement which includes ‘Xinit: Unable to connect to X server. No such file or directory.’


cat ~/.xsession-errors | less

causes an error statement:

cat: /root/.xsession-errors: No such file or directory.

‘shutdown -r now’ restarts to a command prompt and telling me that there are 51 packages for update and 37 are security updates.

Might be worth doing an update :wink:

sudo apt-get update


sudo apt-get upgrade

Whilst I look into that xserver error.

can you also post the output (if any) from:

ls -al /etc/X11/xorg.conf


sudo lshw -C display

and remember Linux commands ARE case sensitive.

ls -al /etc/X11/xorg.conf


-rw-r–r-- 1 root root 117 Mar 15 15:32 /etc/X11/xorg.conf

sudo lshw -C display

returns no errors. The last line is:

resources: irq:18 and then various memory addresses.

I must solve this problem but my eyesight is bad enough to put me on the blind register and I may have got mixed up between l’s and 1’s etc. It will get solved though I am sure.

Thank you very much for your help and patience.


Try renaming your xorg.conf:

sudo mv -v /etc/X11/xorg.conf /etc/X11/xorg.conf.old

then rebooting with

sudo shutdown -P now

then turning on the PC again.

any change ?