Suddenly No Network (SOLVED)

I seem to be never off this forum seeking help for one problem or another and I’ve tried to sort this out myself but I’ve run out of ideas (not that I had many to start with)

For some unexplained reason the network on my Grand-Daughters PC has dropped out and I can’t get it back, it seemed to occure immediately after I changed the swappiness value from 60 to 10 in an attempt to speed up Tux Karting but that might be a red herring , I’ve tried rebooting and completely shutting down and killing the power but it just wont connect, I plugged in a spare usb wireless adaptor and it works fine with that,

Here’s some terminal outputs I took before plugging in the USB adaptor if it’s any help

chloe@Linux2 ~ $ sudo lshw -c network
[sudo] password for chloe: 
  *-network:0 UNCLAIMED   
       description: Network controller
       product: RT3062 Wireless 802.11n 2T/2R
       vendor: Ralink corp.
       physical id: b
       bus info: pci@0000:00:0b.0
       version: 00
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=32 maxlatency=4 mingnt=2
       resources: memory:ea000000-ea00ffff
       description: Ethernet interface
       product: RTL-8139/8139C/8139C+
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: e
       bus info: pci@0000:00:0e.0
       logical name: eth0
       version: 10
       serial: 00:11:5b:36:8f:7f
       size: 10Mbit/s
       capacity: 100Mbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=8139too driverversion=0.9.28 duplex=half latency=32 link=no maxlatency=64 mingnt=32 multicast=yes port=MII speed=10Mbit/s
       resources: irq:18 ioport:ec00(size=256) memory:ea014000-ea0140ff
chloe@Linux2 ~ $ nano /etc/network/interfaces
chloe@Linux2 ~ $ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

chloe@Linux2 ~ $ iwlist scanning
lo        Interface doesn't support scanning.

eth0      Interface doesn't support scanning.

Many thanks


What’s the output from:

lsmod | grep rt


lspci -vnn | grep -i net


rfkill list

Have you ever had to compile any drivers for this wireless adapter ?

chloe@Linux2 ~ $ lsmod | grep rt
gameport 15060 1 snd_ens1371
parport_pc 32114 1
parport 40930 3 ppdev,parport_pc,lp
chloe@Linux2 ~ $ lspci -vnn | grep -i net
00:0b.0 Network controller [0280]: Ralink corp. RT3062 Wireless 802.11n 2T/2R [1814:3062]
00:0e.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ [10ec:8139] (rev 10)
chloe@Linux2 ~ $ rfkill list
0: phy0: Wireless LAN
Soft blocked: no
Hard blocked: no
chloe@Linux2 ~ $

Have you ever had to compile any drivers for this wireless adapter ?

Not that I’m aware of but last night when I was trying to force version TuxKart 8 to version 7 I clicked “Mark all upgrades” and applied and it seemed to download a lot of Linux header stuff which I thought was strange it could have something to do with that


Hmm … for some reason rt2800pci isn’t being loaded.

What happens if you run:

sudo modprobe rt2800pci

Be aware … if that works, it may not survive a reboot … but we can fix that.

Ok I disconnected the usb adaptor then run the command it then attempted to establish a connection then a dialogue box popped up asking for password, I entered that then another box opened up asking for the network key ( the key was already pre-written), I confirmed it was correct then clicked “connect” but the network icon just keeps endlessly circling and no connection, I then plugged the usb adaptor and it connected instantly with that

See this posting (to move the default.keyring):

I’m sorry Mark but I’m not sure where that posting relates to my problem so unsure what to do next ?

OK, if you’re sure you used the correct keyring password.

Try opening NetworkManager, and deleting ALL wireless connections … then close NetworkManager.

Then recreate the connection in the normal way.

Ok I deleted all network connections rebooted, but no attempt was made to establish a connection clicking on the network icon showed no no available networks , I then tried to manually add the connection still nothing, I then plugged in the usb adaptor and it connected instantly without even having to input the network key, I think it did that because it assumed the data I used to try and manually establish a connection earlier

What’s the output from:

modinfo rt3562sta

BTW, as you rebooted try:

sudo modprobe rt2800pci

to load the module … THEN see if there are available networks

If still nothing, we can try compiling the STA driver ?

chloe@Linux2 ~ $ modinfo rt3562sta
ERROR: modinfo: could not find module rt3562sta
chloe@Linux2 ~ $ 
sudo modprobe rt2800pci

Shows the network but fails to connect

Open a terminal and run these commands in sequence:

sudo modrprobe -r rt2800pci


sudo apt-get install linux-headers-generic build-essential


mkdir ~/rt3062sta-driver


cd ~/rt3062sta-driver




tar -xvf DPO_RT3562_3592_3062_LinuxSTA_V2.4.1.1_20101217.tar.gz


cd ~/rt3062sta-driver/DPO_RT3562_3592_3062_LinuxSTA_V2.4.1.1_20101217


sudo su

(your prompt should change from $ to #)



make install




sudo modprobe rt3562sta

Does wireless spring to life ?

If so, check if it survives a reboot.

Thank you Mark you did it again, it sprung into life and it survived a reboot, but can a few questions if that’s ok

1 What went wrong and did I cause the problem ?

2 What did you actually do to fix it ?

3 If I did cause the problem what did I actually do and how do I avoid doing it again ?

Anyway Thank you again for your help


To tell the truth I’m not 100% sure what happened … but it’s unlikely anything you did … I can’t say for sure because I don’t know what you’ve been messing with :wink:

For some reason the (built into the kernel) rt2800pci driver is no longer working (or even loading) … possibly a kernel or firmware update broke things (regression).

So I had you download the proprietary (staging) driver from Ralink (actually a pre-modified version from my dropbox), then compile and install it.

It shouldn’t break again, even with a kernel update.

Ok thanks again :slight_smile:

I have one other little irritating problem concerning that PC

You’ll probably remember helping me sort out TuxKart and you suggested i force version back to v7 from v8 which worked the only problem is that although I locked version in symantic as you also suggested , Update manager is wanting to update back to v8 so i always have the blue icon, is there anyway I can stop peppermint from trying to update to that version ?


Have you tried running an update ?

did it get updated ?

If you’ve locked the version it shouldn’t update.


Oh, do you mean mintupdate (shield icon in the system tray) keeps warning you there are updates available ?

Have you tried running an update ?

No because it wants to update to v8 and I dont want that, i did try sudo apt-get update from the terminal but it changes nothing I still have the blue icon


Do you mean the Shield icon in the system tray ?

Do you mean the Shield icon in the system tray ?


2 mins … testing mintupdate, as I don’t use that anymore :slight_smile: