Touchpad left button not working


The left button on my Sony Vaio touchpad has stopped working. I have it set for right hand, the touchpad itself and the right button are fine. I have moved the slide bar in the mouse and touchpad settings but it still won’t work.

I’m running Mint.

Anyone have have any ideas? It’s very annoying as I can’t drag and drop or copy and paste.


Let’s see if the imps protocol works.

Open a terminal (Ctrl+Alt+T) and run the 2 commands in sequence:

sudo modprobe -r psmouse


sudo modprobe psmouse proto=imps

does the touchpad work as it should now ?

If so, we can make that permanent.

The above commands will NOT survive a reboot … so rebooting will get you back to where you are now.

So will:

sudo modprobe -r psmouse


sudo modprobe psmouse

That didn’t work. :frowning:

Are you 100% sure this isn’t a hardware fault ?

What happens if you select an earlier kernel at bootup ?

Immediately after turning on your PC, hit and hold the "“Shift” key … you should eventually be presented with the GRUB menu.

at the GRUB menu … use the down arrow to move to “Previous Linux Versions” or similar … and hit enter.

Select the top entry, and hit enter to boot.

Does the touchpad now work properly ?

I don’t see ‘Previous Linux versions’.

This is what appears after holding down shift:

LinuxMint, with Linux 3.2.0-23-generic
LinuxMint, with Linux 3.2.0-23-generic (recovery mode)
Memory test (memtest 86+)
Memory test (memtest 86+), serial console 115200

Have you tried a USB mouse to see if its left button also doesn’t work ?

Can you open a terminal and run:


A little while box will open.

Put your cursor inside this box, and press the left touchpad button.

Do you get a “Buttonpress event” in the terminal ?

I have managed to get hold of a usb mouse and yes the button works.

I did try the xev box and the button still doesn’t work.

So I presume it’s the touchpad that’s faulty.

You can check for the capabilities of the Touch Pad as recognised:
First, find the name of your touchpad:

xinput -list
xinput list-props "<name of your touchpad" | grep Capabilities

This should return something like this:
Synaptics Capabillities (296): 1, 0, 1, 1, 1, 1, 1
Look out for the first item as in:
From left to right:

(1) device has a physical left button
(0) device does not have a physical middle button
(1) device has a physical right button
(0) device does not support two-finger detection
(0) device does not support three-finger detection
(1) device can configure vertical resolution
(1) device can configure horizontal resolution 

If the first item is 0 then that would indicate that feature is missing

When I enter xinput -list the only reference to a touchpad is " SynPS/2 Synaptics Touchpad".

If I enter that it comes back unable to find device. I have tried without SynPS/2 as well.


xinput list-props "SynPS/2 Synaptics TouchPad" | grep Capabilities

Still can’t find the device.

Hi tanya

Just a thought but if all else fails it might be worth trying booting up from a live cd/dvd or live usb drive if you have one and seeing if left click works, if nothing else it might tell you if it’s a hardware issue

Good luck


Still can't find the device

It needs to be exact copy of the returned name (case sensitive)

xinput list-props "SynPS/2 Synaptics TouchPad" | grep Capabilities

What’s the output from:

dmesg | grep -i syn

Sorry I missed the capital P in TouchPad!!

I have Synaptic Capabilities (293): 1,0,1,0,0,1,1

If xev gave NO output when you hit the left button, I’m leaning towards the button being broken.

But as Emegra suggested, it might be a good idea to test it booting from a LiveCD or LiveUSB

dmesg | grep -i syn

Sorry Mark I missed this.
I’ve entered this code but I don’t know how to do a Screen print on Linux and obviously I cant copy and paste. Will take me a while to type all the text.

Thanks Graeme, I will try the Live CD tomorrow.

I've entered this code but I don't know how to do a Screen print on Linux and obviously I cant copy and paste. Will take me a while to type all the text.

You should be able to copy and paste by using ctrl c to copy and ctrl v to paste


Forget my last post just realised you can’t highlight :-[

Okay. Lol