Tutorial - Installing PeppermintOS Two on an Acer Aspire One AOA110L ZG5


There’s a new tutorial for installing PeppermintOS Five here:


In this tutorial we will wipe the default OS (Linpus Lite) from the internal 8GB SSD and install PeppermintOS (Two) Linux is its place.

Why would you want to do this … Well Linpus Lite, though small and fast is based on Fedora core 8 which is a very old Linux distribution that has been out of active development for quite some time … so Linpus Lite doesn’t receive any updates, and it is nearly impossible to get any new software to install without jumping through hoops, if at all.

PeppermintOS (Two) on the other hand is based on the MUCH more recent Ubuntu 11.04, but uses the LXDE desktop which is more like a “normal” desktop environment, and is also small and fast … it also has the added benefit of having access to the Ubuntu software repositories, so it is VERY easy to install the latest software.

If you want a quick look at what the PeppermintOS desktop will look like, see here:

As you can see it has a single panel at the bottom, an application menu, a system tray, and a workspace that you can put application icons (shortcuts), files, or directories on … in fact (good or bad) it’s very similar to the Windows layout.

I’m going to set out this tutorial in stages … the first stage will tell you how to download the PeppermintOS ISO image, and how to use a Windows PC to write it to a 1GB or larger USB Stick.

The following stages will deal with installation, then some post-installation tasks to get Peppermint “just right”.

These instructions may look complex at first glance, but take it from me it is easier than it looks :slight_smile:


I’ve been told that some people are having problems using the new version ( of Universal USB Installer to write the PeppermintOS ISO image to their USB sticks … so here are links to some other versions/applications that should work in Windows.

Universal USB Installer (from my dropbox)

Linux Live USB Creator (worked for banko <thanks banko :)> and also provides persistence)

Unetbootin (doesn’t provide persistence, but can still be used for installation, and non-persistent test driving)


OK, Stage 1 …

Downloading the PeppermintOS (Two) ISO image (to a Windows PC) and writing it to the USB stick

The following instructions are for creating a PeppermintOS LiveUSB stick using a Windows PC … if you need instructions for creating one on a Linux PC, let me know.

On your Windows PC, download the PeppermintOS (Two) ISO image from here:
or see here:

Once you’ve got the ISO image … download Universal USB Installer from here:

Start Universal USB Installer, and at …

Step 1 … In the drop down list, select PeppermintOS (Two)
Step 2 … point it at the ISO image you downloaded
Step 3 … Choose your (already plugged in >= 1GB) USB stick … probably best to let it format it too, so backup its contents first.
Step 4 … Set the slider to the largest persistence file it will allow you… so you can save changes. (if you want to test drive it first)

Heres a pic of the Universal USB Creator interface


Click Create … and wait till it’s done … it will take a while, and may appear to have stopped … but just wait till it says it’s “Done” … as in the following pic

Pic of Universal USB Installer … Installing to USB Stick


Once the LiveUSB has been created, click Close, plug it into your AA1, then turn ON your AA1 … as soon as you see the first screen (Acer Empowering People), hit the F12 key to access the boot device selection screen … and select the USB HDD as the drive to boot from and hit Enter to boot.

When asked, select “Try Peppermint” not “Install Peppermint

Be aware … running from a USB stick will be quite a bit slower that running it from the internal SSD after installation, so don’t draw any conclusions about speed at this point :wink:

I can tell you that once installed, it takes about 15 - 20 seconds longer to boot than Linpus Lite … but once booted it loads/runs applications just as quickly … and has access to all the latest software.

Once you’ve got to a working desktop, you can either test drive Peppermint from the USB stick … or you can just click the “Install Peppermint” icon that will be on the desktop.

If/when you decide to install Peppermint to the internal SSD (and it IS worth it) … Here’s the list of post installation tasks I needed to do to get Peppermint “just right” for me … and the approx time it will take … I’ve included these here just for information, we’ll go through these later in the tutorial.

  1. enter the wireless key and connect … 1min
  2. enable wireless autoconnect … by default you had to turn wireless on every boot … 1min
  3. enable the extra repos … 2min
  4. enable auto login (if you want) … 2min
  5. run an update … 7min
  6. install apt-xapian-index
  7. install firefox
    8.) install vlc
  8. install libreoffice-writer
  9. install libreoffice-calc
  10. install thunderbird
  11. install pidgin (or amsn) IM client
    13 install skype
  12. install lubuntu-restricted-extras
  13. apply the fix for the right-hand SD card reader not working … 3 mins
  14. apply the fix for the microphone not working in skype. … 5mins

The software can be installed with a single command, and will take about 5 mins to install.

Stage 2 …

Using the LiveUSB you just created to install PeppermintOS (Two) to the internal SSD

This part is very easy … Plug the LiveUSB into your AA1, then turn ON your AA1 … as soon as you see the first screen (Acer Empowering People), hit the F12 key to access the boot device selection screen … and select the USB stick as the drive to boot from and hit Enter to boot.

When asked, select “Try Peppermint” not “Install Peppermint

When you get to the desktop … Click the Install Peppermint icon on the desktop, and follow the onscreen prompts to install Peppermint

When you get to the Allocate drive space part of the installer, allow it to replace Fedora release8 (werewolf) and use the whole drive.

When you get to the part where it ask you for a username and password etc … here’s a few hints -

You will be asked for things like -

Re-Enter Password:

The Computername field will probably be autofilled for you after you’ve entered your name … but you can change it.

Make sure the Username is all lower case, and no spaces

Here’s what I used for MY AA1

Name: Mark Greaves Computername: mark-AA1 Username: mark Password: whatever_you_want Re-Enter Password: whatever_you_want (again)

so keep the username short and lower case (and no spaces)

Password rules … I think it needs to be at least 6 digits and at least one number … and remember, passwords ARE case sensitive.

It may be a good idea to write down what you enter here, so you don’t forget them … you WILL need at least the Username and Password later on, so don’t forget them.

Stage 3 …

Entering your Wireless key

When the installation has finished and you have rebooted to the internal SSD … at the login screen enter your username, then password.

When you are fully booted to the desktop …

Click the NetworkManager icon (looks like little steps in the system tray, by the clock) on the bottom panel … you should be pesented with a list of available wireless networks.

Click YOUR network, and you should be prompted for the WEP or WPA(2) key.

Enter your key, and click Connect.

That’s it… you’re connected :slight_smile:

Stage 4 …

Enabling wireless autoconnect (so you don’t have to manually connect every login).

Click the “NetworManager” icon (bottom panel, looks like some steps by the clock) and select Edit Connections, when a window opens, select the Wireless tab, click your wireless connectin to highlight it, and select Edit, enter your password if asked … now put a tick in:

Connect Automatically
Available to all users

Click Save.

You may have to move the window up the screen to see the Save button.

Stage 5 …

Enabling the extra software repositories

In the menu, go to System Tools > Synaptic Package Manager, enter your password, when Synaptic starts -

Go to Settings > Repositories … when a new window opens -

On the “Peppermint Software” tab, make sure all boxes are ticked.

On the “Other Software” tab, make sure all boxes are ticked EXCEPT the cdrom:[Peppermint 2 - i386 (20110427)]

Click Close

Click the Reload button.

Close Synaptic.

Stage 6 …

Enable autologin (if you want)

In the menu, go to Accessories > Terminal

When a terminal opens, enter:

sudo gedit /etc/xdg/peppermint/lxdm/lxdm.conf

and hit enter, then your password when asked … be aware when entering your password nothing will be echoed to screen, not even *****, but it is going in, so just enter your password and hit enter.

Gedit should open with a file that starts

[base] # autologin=dgod # session=/usr/bin/startpeppermint

If it opens an empty file … close WITHOUT saving, and try again … you must have entered the command incorrectly

Change the second and third line to read

[base] autologin=your_username session=/usr/bin/startpeppermint

so MINE would read

[base] autologin=mark session=/usr/bin/startpeppermint

But obviously you need to use YOUR username, not mark

and make sure you remove the comment (#) and space from the beginning of those 2 lines

SAVE the file, and exit Gedit.

You shouldn’t be prompted for your username and password at next boot.

Stage 7 …

Run a System Update

In the menu, go to System Tools > Update Manager … enter your password if prompted.

Now I need to explain something here … UNDER NO CIRCUMSTANCES ever hit the “Upgrade” button (at the top) here … that will attempt to update your system to UBUNU 11.10, not PeppermintOS … and will probably break your Peppermint installation

Instead, click the Install Updates button (underneath the listed updates) and wait until finishes before closing.

Stage 8 …

Installing the extra software (part one).

OK, we’re going to install the extra software in 2 stages … the first stage to install most of the software … but we’ll leave out lubuntu-restricted-extras just so I can show you one of the “normal” way of installing software through the Synaptic package manager, where we’ll install lubuntu-restricted-extras.
(you WILL want this package, because it installs support for mp3, flash etc. but we’ll do it in a min)

In the menu, go to Accessories > Terminal

When the terminal opens, enter:

sudo apt-get update

hit enter and your password when asked … when that command finishes, enter:

sudo apt-get install firefox vlc libreoffice-calc libreoffice-writer thunderbird apt-xapian-index skype pidgin

hit enter, and your password if/when asked … and if it prompts you for a y/n, hit y and enter.

Stage 9 …

Installing the extra software (part two)

OK, in the menu, go to System Tools > Synaptic Package Manager

When Synaptic opens, give it a second to update itself, then in the “Quick Filter” box enter lubuntu-restricted-extras
(be sure to start that with an “l” (L) … you DON’T want to install the ubuntu-restricted-extras)

Now in the main window you should see a line that reads lubuntu-restricted-extras with a little box at the beginning of that line.

Click the little box, and select Mark for Installation

Another window will probably appear saying it needs to “Mark additional required changes?” … click the Mark button to accept the dependencies.

You should be back at the main Synaptic interface … Click the Apply button (on the toolbar at the top) … and the software will be installed

Be aware - at some point during this installation a window will open asking you to accept the license for the ttf-mscorefonts-installer, tick the box to accpet the license, and click OK (or Next or whatever it is) … the reason I mention this is sometimes it opens behind the Synaptic window, so you MAY have to minimise the synaptic window to see it … the installation will NOT complete till you have accepted the license.

Stage 10 …

Fixing the right-hand SD card reader.

Open a terminal and enter these 2 commands:

sudo cp /etc/default/grub /etc/default/grub.bak

(hit enter, and your password when asked)

then run:

sudo gedit /etc/default/grub

(hit enter, and your password if asked)

When gedit opens, look for the line:

and change it to:
GRUB_CMDLINE_LINUX_DEFAULT=“quiet splash pciehp.pciehp_force=1”

(enlarged only to make reading easier, so you don’t mix up i and l)

Visually check the edit to make sure there are no spaces where there shouldn’t be, then SAVE the file, and exit gedit.

Back in the terminal, run:

sudo update-grub

(hit enter, and your password if asked)

WARNING - Be 100% sure you enter the next command correctly before hitting enter (probably best to copy/paste AND visually check).

When that command finishes, and leaves you back at a prompt, enter:

sudo sh -c 'echo acpiphp >> /etc/modules'

(hit enter, and your password if asked)

Now reboot, and check if the right-hand SD card reader works.

Stage 11 …

Fixing the Microphone for Skype.

In the menu, go to Accessories > Terminal

When the terminal opens enter:


and hit enter.

The terminal will change to a mixer.

Hit F4 to change to the Capture devices.

Hit the right arrow key … so Capture is light in red (at the bottom).

Hit the Q key till the left volume is at 75% … the Z key will lower if you go too far.

Hit the C key till the right volume is at 0% … the E key will raise it, but you want it on zero

Close the terminal … and make a test call in Skype to test your Mic works.

That’s it … you’re done :slight_smile:

If you want to install any other software, you can do this through the Synaptic package manager, or through the Software Manager.

If you want to place application shortcuts on the desktop … in the menu, right-click the application, and select “Add to desktop

If you have any other questions, or require assistance … feel free to ask.

Enjoy Peppermint, and the ability to install/use up-to-date software. :slight_smile:

This tutorial was written on an AA1 kindly donated by Kath C so it could be used to help other AA1 users … thanks Kath :slight_smile:

A quick addendum

One person who installed PeppermintOS to an Acer Aspire One AOA150-Ab ZG5 (120GB HDD model) reported that the fan was running permanently … this doesn’t appear to be the case on the AOA110L ZG5 (8GB SSD model) … but I’ll add the fix here anyway.


Open a terminal and enter the following commands:

sudo su


echo "options acerhdf interval=5 fanon=60000 fanoff=55000 kernelmode=1" >> /etc/modprobe.d/local.conf




sudo modprobe -r acerhdf


sudo modprobe acerhdf

The fan should now work properly, and only come on when the temperature reaches 60C, and go off again when it’s dropped to 55C.

You can check the temperature by running the following command in a terminal:

cat /sys/class/thermal/thermal_zone0/temp

the temperature will be returned in this format -
60000 = 60C
55000 = 55C
46000 = 46C

If you have to apply this fix … It would be a good idea to keep an eye on the temperature for a short while, just to check the fan does come on when the temperature reaches 60C … be aware, running the command to check the temperature takes a single reading, so you will have to run it again to get another reading.

Original topic:

Hi again Mark. Given your comments when you helped me sort out firefox a few weeks ago, I thought I’d give this OS upgrade a try. However when I try and load from the USB drive on the Acer, all I get is a title line " SYSLINUX 4.04 etc etc" and then nothing else, it just hangs. I’ve tried several of the USB creation programs and they all complete ok but they all give the same result on the Acer. Any ideas?

Rgds, Joe

Attempt to boot from the USB stick again …

When you see the SYSLINUX 4.04 message … hit Tab

What is listed ?

Absolutely nothing I’m afraid. If I keep hitting the tab key eventually it just starts to beep at every stroke. Maybe the iso is corrupt?..Rgds, Joe

It may well be … I’ve just used this:

to create a PeppermintOS LiveUSB (on a Windows 7 PC) … and it worked perfectly on my AA1 ???

Try downloading the ISO again:

Also make SURE you select PeppermintOS Two in Universal USB Installer … and allow it to format the stick too.

Hi Mark,
I downloaded the iso again and did a md5 check on it before putting it on my stick and the same thing. I’ve always let the USB installer format the drive too. My PC is running XP, could this be a factor? If not, I’ll have to try another USB stick, as this is the other common denominator. Thanks anyway.

Rgds, Joe

Should work fine in XP … so as you say, maybe the stick itself.

Have you tried booting the PeppermintOS LiveUSB on another system that is capable of booting from USB ? … just to rule out it being the AA1 itself.

Have you tried it in a different USB slot on the AA1 ?

After a brief honeymoon period I managed to collapse the pepper2 OS and am reinstalling using the tutorial but have encountered this screen.
Advice needed…:

Failed to fetch http://extras.ubuntu.com/ubuntu/dists/natty/InRelease

W: Failed to fetch http://ppa.launchpad.net/kendalltweaver/peppermint/ubuntu/dists/natty/InRelease

W: Failed to fetch http://ppa.launchpad.net/kendalltweaver/peppermint/ubuntu/dists/natty/Release.gpg Temporary failure resolving ‘ppa.launchpad.net

W: Failed to fetch http://extras.ubuntu.com/ubuntu/dists/natty/Release.gpg Temporary failure resolving ‘extras.ubuntu.com

W: Some index files failed to download. They have been ignored, or old ones used instead.

With an active internet connection, can you open a terminal and enter:

sudo apt-get update

(hit enter and your password when asked)
then post the output.

Where had you got to in the tutorial when this happened ?