Ubuntu Start up problem SOLVED

I have a newly installed setup of Ubuntu 12.04 on a Acer Aspire 5755G with Grome3. When I start up first thing on a morning it starts as normal to the point you thing it has finished, but I am unable to do anything. Cannot open any programs, will not connect to wireless or connect when I plug in the LAN wire and cannot shut it down. I have to press and hold the power button to force a shut down. Reboot it and it’s fine all working. Why ? and how do I cure it?

If possible NEVER do a cold shutdown with the power button.

Tomorrow morning, if/when it does it again … hold Alt+Sysrq, and whilst holding them type R E I S U B leaving a couple of seconds between keystrokes.
(some laptops require AltGr+SysRq instead)

for now, run:

sudo touch /forcefsck

That should force a file system check when you next reboot.

Once we know it’s not a kernel panic (REISUB won’t work during a kernel panic), and if it keeps doing it, we’ll see what we can discover … maybe the logs will contain a clue, or maybe we’ll have to remove “quiet splash” from the boot stanza and see if the system gives us a clue where it’s freezing.

Does it get to the login screen ? … and can you enter your password ? … or deosn’t it get that far ?

Try to remember the REISUB reboot trick as it safely unmounts the drives and reboots the system without risk to the file system …

REISUB = reboot
REISUO = power off

I remember REISUB with - Reboot Even If System Utterly Broken

If you want to know what’s going on with those keystrokes … see here:

To me it sounds like your laptop isn’t firing on all cylinders when you start it up. It’s kind of similar to a problem my brother’s laptop (Acer Aspire 5738Z) was having last week. REISUB didn’t work for him mind you, so it was definitely a kernel panic he was having. Managed to sort it though, by booting to a LiveCD eventually and numerous amounts of restarts, but I managed to install a patch which fixed the issue.

Although now I’ve just put him SolusOS, which uses Debian’s stable stuff. Seems to be pretty bulletproof just now. More than I can say for Ubuntu 12.04. Here’s hoping 12.10 will fix a bunch of stuff.

Which patch … and what was it a patch for ?

Was your brothers issue the same … or “similar” … ie. did his only refuse to boot in the morning (I’m assuming when the hardware’s cold, which is odd) ?

Never tried SolusOS, but I’d agree Debian (stable) is about as solid as it gets (sure someone will disagree there :slight_smile: ) … problems arise in getting it set up the way you want, and not so new packages, which may or may not cause you issues down the road.

Thanks. I have written down the instructions and will let you know what happens.
As for starting up, I get the login screen and login, the desktop appears and looks normal apart form I have no wireless icon at the top. It just will not do anything.

Patch for the kernel, it was just an update available on kernel website.

Yup his was similar, only his refused to put up when the hardware was cold period. I had to stick beside my PS3 for a while to let it heat up and then turned it on and it magically worked… I now keep his laptop beside mines where it’s rather warm, or tell him to put it into suspend.

Very odd … I had a “similar” issue with 11.10 on a desktop PC for a while where booting appeared to freeze in the mornings … but it wasn’t freezing, it turned out to be that it just wasn’t kicking the graphics card in, actually more the monitor … turns out that turning off/on the monitor worked (not that that would help on a laptop) … adding vesa=791 (1024x768 16bit) to the kernel boot line also mitigated the issue (though didn’t completely solve it).

Later on, something updated that allowed me to remove that option … as I said … odd ???

@ Markems0

Just a thought, but has this only started happening since installing Bumblebee ?

And does it do the same if you boot Windows in the morning ?

I’m sure more mysterious things have happened. Probably just Linus or one of the other maintainers forgetting to patch something.

It started up and all worked first time this morning. So I will just have to see what happens in the future. Will keep you posted if it continues.


Glad to hear it … Fingers crossed :slight_smile:

Yesterday I was going to post saying everything was ok, but this morning it did it again. I did the Alt REISUB and nothing everything stayed the same. :frowning: This time I had been running windows first so the laptop was physically worm.

It’s Alt+SysRq, not just Alt … are you now saying you can’t get into Ubuntu AT ALL ?

How far does it appear to get in the boot process before locking up ? … as far as the login screen, or as far as the desktop ? … or not even as far as the login screen ?

Did it ever do this before you installed bumblebee ?

If you CAN get in … can you send the output from:

sudo lshw -C display

I’m sure I read somewhere the Nvidia drivers were causing some systems to lock at the Unty interface with Nvidia Geforce 7xxx cards (though I’d expect your to be more recent) … but the beta drivers were OK … that was quite a while ago though.

Can you also send the output from:

dpkg -l | grep nvidia

That output is

mark@mark-Aspire-5755G:~$ sudo lshw -C display
[sudo] password for mark:
description: VGA compatible controller
product: 2nd Generation Core Processor Family Integrated Graphics Controller
vendor: Intel Corporation
physical id: 2
bus info: pci@0000:00:02.0
version: 09
width: 64 bits
clock: 33MHz
capabilities: msi pm vga_controller bus_master cap_list rom
configuration: driver=i915 latency=0
resources: irq:51 memory:d1400000-d17fffff memory:c0000000-cfffffff ioport:3000(size=64)

Not sure if it did it before bumblebee or not.
It gets as far as desktop.
output from dpkg -l | grep nvidia is

mark@mark-Aspire-5755G:~$ dpkg -l | grep nvidia
ii bumblebee-nvidia 3.0-2~preciseppa1 nVidia Optimus support using the proprietary NVIDIA driver
ii nvidia-common 1:0.2.44 Find obsolete NVIDIA drivers
ii nvidia-current 302.17-0ubuntu1~precise~xup1 NVIDIA binary Xorg driver, kernel module and VDPAU library
ii nvidia-settings 302.17-0ubuntu1~precise~xup3 Tool of configuring the NVIDIA graphics driver

I know it is bad but I needed some info for work so i forced a shutdown and rebooted it was then fine

Can you run:

lspci -vvnn > ~/lspci.txt

You’ll then find a file called lspci.txt in your home folder … can you attach that to your next reply.

Done that and the file is attached. :slight_smile:

OK, lets look through the logs and see if we can spot anything …


cp /var/log/kern.log ~/kern-log.txt


cp /var/log/syslog ~/syslog.txt


dmesg > ~/dmesg.txt


cd ~


tar -cjvf logs.tar.bz2 kern-log.txt syslog.txt dmesg.txt

You’ll now find an archive called logs.tar.bz2 in you ‘Home’ directory … can you attach that to your next reply.

This isn’t anything to do with resuming from suspend/hibernation has it ?

As requested i have attached the log file.

I do not think it has anything to do with resuming or hibernating it only happens when I first start up, or so far it has.

Well so far I can’t spot anything in those ???

I’m wondering whether to try the 3.4 kernel, and see if that helps … before we try, do you know how to select (and boot into) an earlier kernel at the GRUB menu ?

No have not got a clue. Is it worth waiting till next time it dose it and see if the REISUB works when I do it property? and if it dose not how do I get out of it with out forcing a shut down? ???

If holding Alt+SysRq whilst typing REISUB doesn’t work … it’s extremely unlikely ANYTHING will (that should work in all cases except a kernel panic … usually indicated by flashing keyboard lights on a desktop PC) … so you’ll have no option other than a cold power off (power button).

It might be interesting to see if a different kernel does the same thing in the morning …

To boot an earlier kernel, when you turn on the PC (as your system is set up as a dual booter) you should be presented with the GRUB menu (where you’d normally select Windows or Linux) … that menu will have an item called “Previous Linux versions”, click that, then select the top item in that sub menu, and hit enter.

See if it still misbehaves with the earlier kernel … if it doesn’t, it may be some kind of kernel regression … then we’ve got 2 options, set the earlier kernel as default, or try a newer kernel.