Unable to mount Linux pendrive distribution

I have tried to mount several distributions by means of a universal USB installer. I have tried UBUNTU and SUSI amongst others.
The Kernal starts to count up then the computer just freezes and I have to use the on-off button to reboot.
I have a Dell inspiron 530 desktop and the pen drive works fine when I try it on my desktop at work.
All comments welcome?

Can you tell us exactly what is displayed on screen … are there any error messages ?

Have you tried a LiveCD instead ? … not all PC’s can boot from USB sticks.

Is this a problem with installation to the hard drive, or will the LiveUSB not start up at all ?

I used to have a PC that I built myself. I had a duel boot, windows and ubuntu. I bought this Dell Inspiron because of the relationship with Linux and thought I could do the same,
I downloaded a ubuntu image and created a CD. I tried to install but could not get ubuntu to load. I also tried to run from the disc but still no good.
This week at work a colleague told me he was trying various distributions on USB and gave me the web site. I attempted to run from the USB and got the same condition as I had with the CD some time ago.
I thought that it might be because I bought a windows PC from Dell and they did something to the hardware to prevent me from duel booting. I now think that was unlikely.
I asked at work and they sugested this Linux forum. I looked for similar issues but decided to post my comment.
The USB starts. The Kernal starts to install. The screen goes blank (Not off) and then nothing.
How do I get a screen dump if the PC is not in windows or Linux mode? (I don’t have a still camera)
Currently all I want is to run from the USB. If I can get this to work I will partition my hard drive and again enjoy the different PC experience I get with Linux.

You might want to take a look at this bug report for the Inspiron 530:

There hasn’t been any activity on it for some time so I would guess it was solved… but may be worth checking.

The solution was to do change the BIOS setting from IED to RAID, but this will not help you if you are dual booting Windows, as it will cause Windows to become unbootable… the other fix which WILL be OK with Windows is to set the all_generic_ide kernel boot parameter.

As a matter of interest, what graphics card do you have ?
Which version of Ubuntu are you trying ?

A blank screen sounds like a graphics issue…

If it’s an nVidia GeForce 8600 GT, have you tried the nomodeset kernel boot parameter ?

Instructions for selecting the nomodeset kernel boot parameter

Boot from your Ubuntu LiveCD/LiveUSB, and as soon as you see:


displayed at the bottom of your screen… keep hitting the Space Bar until…

A screen similar to this will appear and ask you to select a language… select English and hit Enter:
(if you get to the purple Ubuntu screen with the 5 or 6 dots, you missed it and will have to try again)


Press the F6 key, and a menu will open as in the above picture.

Use the arrow keys to move to the nomodeset option, and hit Enter (or spacebar) to select it. (it should now have ar X next to it).

Now select “Try Ubuntu without installing” and hit enter to boot.

If this works, let me know and I’ll tell you what to do next to fully install Ubuntu.

Mark, Having read your suggestions I decide to bite the bullet and install UBUNTU from the USB pendrive.
I was sure that any hardware issue such as the graphics card could be overcome with a complete install.
The first boot up froze the computer after I was asked for my password.
Imagine my surprise tonight when I booted the UBUNTU installation, and no issues.
I am currently using the UBUNTU distribution and enjoying every minute.
Just one thing. I chose the “Under windows 7” option. Was this the right thing to do?
Thank you very much for your rapid response to my post. It was this which convinced me to persist.
I will be checking out the Dell bug report and if I do have any further issues I shall forward my graphics card details.
Thanks again!

Glad it worked for you… If you are offered any updates for GRUB, don’t install them yet… there was an issue with a WUBI installation with Ubuntu 10.04 where a GRUB update stopped the system from booting, but AFAIK it has been fixed in later releases… but it would probably be a good idea to lock the GRUB version anyway (so it never gets updated), just in case.

Go to System > Administration > Synaptic Package Manager

When Synaptic starts, in the quicksearch enter:
look for grub-pc in the “Package” column, Click on this once, to highlight it.

Now in the Synaptic menu, select Package > Lock Version … a little padlock should appear in the little green box at the beginning of the grub-pc line.

Now back in the quicksearch, enter:
look for grub-common in the “Package” column, Click on this once, to highlight it.

Now in the Synaptic menu, select Package > Lock Version … a little padlock should appear in the little green box at the beginning of the grub-common line.

That’s it, you’re done :wink:

To summarize… you want to lock the version of grub-pc and grub-common … This will stop any future updates to the GRUB bootloader, but ALL other updates will still be applied.

Thanks Mark

Ubuntu seems to be much more user friendly since I last used it.

Best Regards

Just one thing,
I find that, if I log into windows 7, finish the session and then reboot into Ubuntu, the boot does not work and the screen hangs following input of my password.
I can move the cursor around the screen by means of the mouse but the desktop does not appear.
I then reboot and go into the repair mode. I choose the repair packages option and reboot again.
This normally resolves the issue.
Is this normal for a duel boot machine? or is it connected to the fact that I installed by using the windows 7 option?
and can this issue be resolved?

What happens if you boot to Ubuntu, then shut down, then boot to Ubuntu again ? … does it boot cleanly ? (ie. is this ONLY caused by booting into Win7).

No this is not normal.

Tonight I had to run the repair mode twice before Ubuntu installed to the desktop. Last night I only worked in Ubuntu so the windows 7 thing might be a red herring?
I am beginning to think that it might be a hardware issue.
I am not really that concerned about this issue as it does eventually boot. I just thought with your Knowledge, there may be a patch or evidence of this issue before that would enable me to resolve this little inconvenience.
Is there a different Linux distribution that might be more comparable to my Dell inspiron 530 or do you recommend I carry on regardless?

As an install from “within” Windows (WUBI install), you’re limited to Ubuntu or Linux Mint (which is really just Ubuntu in a different colour with a few tweaks).

So unless you want to do a “proper” installation, I’m afraid your only option is to try removing the WUBI install and try reinstalling.

There are risks associated to a “proper” installation, as it will require resizing your Windows partition… there is always a small risk of corruption attached to partition manipulation.

If you hold off for a while, I’ll see if I can discover anything that might solve the issue… but don’t hold your breathe, there is much less info out there to help fix WUBI type installations… and no way I can reproduce and test the issue.

You could try unlocking the grub-common and grub-pc packages in Synaptic again, and see if that makes any difference… but make sure you don’t accept any updates to GRUB… just test it, then lock them again, and let me know.

Hello Mark,
I have decided to create a partition, format using EXT4 file format and use the pendrive to do a full install to this partition.
Once it is working I will then uninstall the WUBI installation as I would a standard windows application.
I am guessing that a 10Gb partition would be adequate?
Please advise!

10GB will be fine as long as you don’t plan on installing millions of software packages.

Personally I’d uninstall the WUBI insttallation first, and get back to just Windows with its own bootloader… then do the proper installation.

But that is probably me being over cautious… I have no idea how the WUBI bootloader will affect the GRUB bootloader when youu do a “proper” install…

It will probably be OK because I’m pretty sure WUBI still uses the Windows bootloader… but can’t say for sure, as I don’t use WUBI.

How I’d do it.

Uninstall WUBI/Ubuntu, and make sure I’m back to the Windows bootloader.

Boot to a LiveCD, and use Gparted to resize the Windows partition, leaving 10GB free at the end of the drive.

Reboot to the LiveCD, and select “Install Ubuntu”

And just tell the installer to use the “largest free continuous space” (or however it phrases it).

Thank you Mark.

Will do and I will let you know how I get on.

Hi, I may not have said that I had two operating systems om my computer already. I HAD Vista and 7.
I did uninstall Ubuntu WUBI, I resized the widows partition using Gparted. but discovered I could only have four partitions on any one drive.
The hard drive already had a recovery and Dell utilities partition. this would have made five.
I then formatted the Vista drive to FAT32 and resized to include the unallocated 10Gb.
I put the Ubuntu CD in the drive and rebooted the computer.
When I pressed install I got this message.
No root file system defined. Please correct this from the partition menu.
I tried several combinations from what I thought was the partition menu with no succsses.
I know this makes me a complete novice but please help!

Without deleting one of the Windows partitions, you are stuck…

You CAN have more than 4 partitions, but you can only have 4 PRIMARY partitions

So normally you’d set up the 4th partition as an EXTENDED partition, then create as many LOGICAL partitions as you want within the extended partition.

But as you already have 4 primaries, you’d have to delete one :frowning:

I have deleted the Vista partition and want to use this partition for Ubuntu.
I cant get past the “No root file system defined. Please correct this from the partition menu.” message.
I have tried installing to an unallocated partitiion.
I have formatted to ntfs and tried to install
I changed the drive letter in widows 7 and tried to install.
Can you explain what the message means as I feel this is the key to my current dilema?
Just one thing though. I have had the same boot issues with the liveCD as i did with the WUBI installation

Before you do anything else, and remove the Windows bootloader, as it’s a Dell, can you check to see if the drive is being controlled by RAID in the BIOS

OK, / is the root of the Linux file system (similar(ish) to C:\ in Windows)

When you get to the partitioning part of the installer, select “Advanced”, then create a EXT4 partition, and mount it as /
(ie. select “/” as the mount point.)

Ideally you would create an extended partition, then inside that create 2 partitions
one twice the size of your RAM, and mount that as swap
and one using the rest of the space formatted as EXT4 and mounted as /

Let me draw your attention back to this bug report:

Here’s the bug description -

When configuring the SATA drive in IDE mode for the Dell Inspiron 530, the Gutsy 20071016.1 alternate installer doesn't detect the drive. So, it just fails with the error message: [b]No root file system is defined[/b].

As mentionned in the syslog file, I tried booting with the irqpoll kernel parameter and the disk is still not detected.

When configuring the SATA drive in RAID mode, the installation completes successfully.


Current Dell workaround/customization for their Inspiron 530n :

All Vostro 200 and Inspiron 530 are configured to use IDE instead of RAID by default. The Dell inspiron 530n includes a customized ubuntu that includes the Dell workaround for that issue, however any attempt to install a new ubuntu version without dell customization leads to computers that does not boot.

Configuring the computer BIOS to use RAID instead of IDE is not a valuable solution since other operating systems like Windows won’t boot without pre-installed SATA drivers unless BIOS is set back to IDE. IDE is the default “compatible” mode.

Now as I said before, there has been NO activity on this bug report since 2009, but it doesn’t half sound like your issue.

1) is your SATA mode set to IDE in the BIOS ?

2) Have you got a spare drive, so you could remove your current drive, change the SATA mode to RAID, and do a test install ?

Then if it works, you could enable the SATA AHCI/RAID drivers in Win7 by following these instructions:

So Win7 will work in RAID mode.

Your other option is to try setting the all_generic_ide kernel boot parameter in Linux.

You could also try setting the nodmraid option… see pics here:
just in case somehow there is some raid metadata stored on the drive.