Upgrading to Peppermint 5

I’m just going to upgraded and have pretty much everything backed up but what I’d like to know is, is there any way to preserve chrome bookmarks and or history and passwords for re use?

Doesn’t google sync do that ?

with Chromium CLOSED

pcmanfm ~/.config

find the folder called “chromium”

right-click on it and select “Compress” … compress it to chromium.tar.gz

save that chromium.tar.gz file somewhere off the PC

After installing PM5, and BEFORE running Chromium for the first time … unpack that archive in the same place in PM5 … so you have
in PM5 … then start Chromium.

I’m sure I answered this.
That worked just fine thanx Mark

NP :slight_smile:

Having used it for a few days now, I can honestly say that the Pep 5 team have done a truly excellent job.
There are on my system though, just 2 problems.
When coming back from a suspend (which I use all the time) the screen flickers constantly until the mouse is put to the top of the screen but then the mouse dissapears, well actually it’s fragmented across the screen.
When going to switch users it just goes to a black screen and hangs and I have to use REISUB to re boot.
Other than that, what an excellent OS

The suspend thing may be solvable with either a graphics driver change, nomodeset, or a “quirk” … can you post the output from:

sudo lshw -C display

The “switch users” thing … do you mean when you log off, it goes to a black screen rather than back to the login screen ?

Sorry for the delay, don’t get home till gone 11.

       description: VGA compatible controller
       product: 82865G Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 02
       width: 32 bits
       clock: 33MHz
       capabilities: pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:16 memory:d8000000-dfffffff memory:d0000000-d007ffff ioport:1800(size=8)

Actually it does it if you log off and if you switch user.

But only when the display is playing up, otherwise it’s ok.

Sorry, I’d lost track of this topic until you posted again :-[

So it only goes to a black screen at logoff/switch user if you’ve previously resumed from a suspend ?

so all the graphics issues are traceable back to a suspend ?

That’s OK I’ve been away since Thursday anyway n

Rather more succinctly put but yes.

Is this a laptop, and if so what make & model?

No Chem, it’s a desktop.
IBM, but don’t know the model.
I rescued it from the skip at work about 5 years ago.

How come you suspend it? I know it’s not a fix, but you could just set it to blank the screen after inactivity rather than suspending it.

I suspect the issue is something in the ACPI config, I’m not an expert on it but I know Mark is a dab hand at those issues :wink:

What happens if you enter suspend from the command line with

sudo pm-suspend --quirk-vbestate-restore

then restore … do you still get graphics corruption ?

Can you also post the output from:

inxi -F

Which may give clues to the model of IBM.

Link to pm-action quirks (14.04) … for my reference:

Thanks for that link, I’ve bookmarked it and I’ll give it a good read on the train home :slight_smile:

[quote author=Mark Greaves (PCNetSpec) link=topic=12022.msg97431#msg97431 date=1409227490]
What happens if you enter suspend from the command line with

sudo pm-suspend --quirk-vbestate-restore

then restore … do you still get graphics corruption ?

Yes, but I could log out without the black screen and log back in.

Can you also post the output from:

inxi -F

Which may give clues to the model of IBM.

Turns out to be a Tinkcentre A50
System:    Host: celticbiker-Home Kernel: 3.13.0-34-generic i686 (32 bit) Desktop: N/A Distro: Peppermint Five
Machine:   System: IBM product: 808577G version: ThinkCentre A50
           Mobo: Intel model: D865GKD Bios: IBM version: 2CKT20AUS date: 10/26/2004
CPU:       Single core Intel Pentium 4 CPU (-HT-) cache: 1024 KB flags: (pae sse sse2 sse3) 
           Clock Speeds: 1: 2992.530 MHz 2: 2992.530 MHz
Graphics:  Card: Intel 82865G Integrated Graphics Controller 
           X.Org: 1.15.1 drivers: intel (unloaded: fbdev,vesa) Resolution: 1024x768@60.0hz 
           GLX Renderer: Mesa DRI Intel 865G x86/MMX/SSE2 GLX Version: 1.3 Mesa 10.1.3
Audio:     Card: Intel 82801EB/ER (ICH5/ICH5R) AC'97 Audio Controller driver: snd_intel8x0 
           Sound: Advanced Linux Sound Architecture ver: k3.13.0-34-generic
Network:   Card-1: Intel 82562EZ 10/100 Ethernet Controller driver: e100 
           IF: eth0 state: up speed: 100 Mbps duplex: full mac: 00:11:25:37:a3:98
           Card-2: Ralink RT3062 Wireless 802.11n 2T/2R driver: rt2800pci 
           IF: wlan0 state: down mac: c8:3a:35:ca:f6:c4
Drives:    HDD Total Size: 3080.6GB (10.3% used) 1: id: /dev/sda model: ST380012ACE size: 80.0GB 
           2: USB id: /dev/sdb model: D3_Station size: 3000.6GB 
Partition: ID: / size: 72G used: 11G (16%) fs: ext4 ID: swap-1 size: 1.57GB used: 0.00GB (0%) fs: swap 
RAID:      No RAID devices detected - /proc/mdstat and md_mod kernel raid module present
Sensors:   System Temperatures: cpu: 78.0C mobo: N/A 
           Fan Speeds (in rpm): cpu: N/A 
Info:      Processes: 203 Uptime: 14:10 Memory: 419.9/1476.7MB Client: Shell (bash) inxi: 1.9.17

Can you try the same thing with:

sudo pm-suspend --quirk-vbe-post

and tell me what happens ?

Exactly the same as the original issue.

Can you run:

cd /var/log


tar czvf ~/Desktop/logfiles.tar.gz kern.log kern.log.1 dmesg dmesg.0 pm-suspend.log pm-suspend.log.1 syslog syslog.1

you’ll now find an archive on your desktop called “logfiles.tar.gz” … can you host that somewhere online, and ost a link to it.

Here you go