USB ports, and now my browser non-functioning


I’m having some severe problems with my Acer-Aspire AOA-110 running Linpus Lite v.1.06.E and would be grateful for any pointers.

Earlier today I was testing out an SD card from my camera in the SD slot in order to check that it was being read successfully prior to taking the Aspire away on holiday with me. To cut a long story short it now will not mount the SD card. It is possible (probable?) that the card might not have been properly unmounted from this machine previously, as I did not know how to do it (I now understand that it is a right-click option).

More worryingly the Aspire will also now not read from my Sandisk memory stick, which it would yesterday, it gives the same ‘Cannot mount [etc]’ error. Both of these external drives have previously worked in this machine.

Looking at advice on the web and using a terminal window I tried using DMESG to look at what it returned. I maybe switched from admin user to root user to do this, I do not recall in what mode I left it in.

Nothing came of trying to fix the USB ports and I resigned myself that that was not the end of the world I could make-do without. But now I discover that my Firefox browser won’t load, and frankly that is a terminal fault for me, and as is the Aspire won’t be coming on holiday with me unless at least that can be rectified.

Does anyone have any ideas? I have a feeling it might be loaded with the original Firefox, v3.0 (not 2.0), but I could be mistaken and it is V2.0. I tried to update the browser last year and for what ever reason it failed. As I now can’t open it I am not sure how to check what version it is.

Thoughts much appreciated!

OK, the default OS on an AA1 is Linpus Lite … Linpus Lite uses the left hand SD slot for expansion of your home directory by using the AUFS union file system.

You home directory contains a lot of settings for applications, and the fuse mountpoints for USB sticks etc.

My guess is that the SD card is corrupted, or the /home directory on the internal SSD … or AUFS is now broken.

First thing to try … the SD card is normally formatted as FAT32 (a Windows file system), so bung it in a Windows PC and check it for errors … if Windows fixes any errors, try it in the AA1 again.

If Windows reports no errors on the drive … you’ll want to check the SSD for errors, this will entail creating a Linux LiveUSB stick, booting to it, and running fsck (file system check) on the SSD.

That’s all covered in this topic:

But before doing that, can you open a terminal by hitting Alt+F2 then entering terminal in the resulting dialog box, then hitting enter.

Once the terminal is open, run these commands:

ls -al


ls -al ~/.mozilla

and post what’s returned in the terminal back here

Also, where you say:-

More worryingly the Aspire will also now not read from my Sandisk memory stick, which it would yesterday, it gives the same 'Cannot mount [etc]' error.

Can you post the FULL error message.

How long till you go on holiday ? … have you considered ditching Linpus Lite (which is a very old OS which no longer recieves any security updates) in favour of a more up to date, and easier to use version of Linux ?

See here:

My poiint is, if time is a limiting factor, it may be quicker to just install PeppermintOS Two, rather than diagnose/fix this issue.

PeppermintOS will also give you mouse click access to all the latest software … it’s what I use on my AA1 :slight_smile:

Hi Mark,

Thank you very much for your message. In reply:

  • I ran a check on the SD card from my Windows desktop and it has no identified errors.
  • I’ve held off trying to check the SSD for errors for the time being, as indicated (and also because of my stick/mount issue)
  • I ran the two commands, the first returns maybe 40-50 lines of data, the second returns four lines. I don’t know how to get them onto my desktop to post them here.
  • The error from the Sandisk memory stick in full is as follows: ‘Failed to mount “8G Removable Volume” Cannot create mount directory’.
  • I go on holiday on Friday pm, so about 5.0 days to go.
  • Yes I have considered a different OS as I appreciate that Linpus Lite is not very user friendly, and rather too easy to break. I’d be willing to give installing Peppermint a try, but how could I achieve that with non-functioning USB ports? Catch-22?


I think you’ll find your USB ports are working perfectly … the only problem is that LINPUS cannot mount them because of a screwed up file system.

They’ll work fine for installing PeppermintOS (or even reinstalling Linpus Lite) :slight_smile:

Though obviously the LiveUSB stick will need to be created on another PC.

Give it a go … you can always make your mind up after creatng/testing the LiveUSB :wink:

Alternatively, I’d need the output from those commands … couldn’t you copy them to a text fie, bug that on the SD card, then move the SD card to the PC you’re using to post here ?

At the very least if you create a Peppermint LiveUSB with persistence (in the tutorial), you’ll be able to boot from the LiveUSB, select “Try Peppermint”, and end up with a working Peppermint desktop that hasn’t made any changes to the SSD … so you’ll be able to use the netbook whilst on holiday, then we can try fix the Linpus installation when you get back … or you can just install Peppermint and have done with it :slight_smile:

Be aware running Peppermint from a LiveUSB wll be a lot slower (particularly to boot) than it will be once installed to the SSD … so don’t draw any “speed” conclusions … but it will make your netbook usable whilst on holiday :wink:

Great, thanks for the quick reply. I was going to quickly post and say that yes you’re right re: the USBs, right after my last post I plugged in an external mouse and it works fine.

I’ll look at getting Peppermint onto a stick, and it working. I’ll report back.

p.s. No I can’t get the command output onto the SD as Linux won’t recognise/mount the SD card. At least I assume that that is what ‘cannot mount’ means, something akin to ‘not recognised’/‘we can’t speak to it’.

If you highlight the text in terminal, then use ctrl+c to copy that text, paste it into a text file and then just attach it to your next post.

I’ll try to explain …

Windows mounts drives/partitions as separate “drives” c:/ d:/ etc. … Linux on the other hand uses a unified file system, so drives/partitions re mounted as a “directory” that is part of the directory tree that starts at / (root).

Linpus is trying to mount your SD card and USB sticks at a location that doesn’t exist (or is corrupted) … ie. fuse (the application that mounts them) is being told to mount the drives at /home/.gvfs/name_of_mountpoint … but as your home directory is screwed, it cannot find the place to mount them.

On top of that is the way Linpus uses AUFS to allow the left hand SD slot to be “overlaid” on the main file system to allow expansion of your home directory … so screwing the home directory on the SD card can create major problems.

Peppermint doesn’t use AUFS, so this isn’t an issue … it does however mean that the SD card won’t automagically expand the home directory … this DOESN’T mean the SD card cannot be used, it just means that you’ll have to select the SD card as the location to save files when saving them (same as you would if you wanted to save something to a USB stick, or right-hand SD card … but it DOES mean unplugging the SD card whilst in use can ONLY screw the SD cards contents, not the file system as a whole.

Bet that’s now as clear as mud … so if you have any questions, feel free to ask :slight_smile:

Problem is … his browser isn’t working on that PC, so he can’t post from it … neither can he copy them to a text file and bung it on a USB stick or SD card as those aren’t mounting properly.

Not to mention Ctrl+C in a terminal = Cancel … in a terminal you’d have to Ctrl+Shift+C to copy :wink:

Thanks Mark, No your explanation makes a lot of sense, how interesting.

You really do have a knack for making the complicated understandable.

I’m still going to go down the Pepper mint route as previously mentioned.

I’ll report back. Many thanks for all the help so far.

@Mark - Oh yeah… good point. ???

I’m half-way through the estimated 4hr download of Peppermint :o

Yeh, the servers that Peppermint use for hosting the ISO images have always been a little on the slow side… but trust me, it’ll be worth the wait :wink:

After Linpus Lite … you’ll wonder why you didn’t install Peppermint earlier, it’s that much better … and it has all the latest software available with a few mouse clicks :slight_smile:

Any suggestions on checking the integrity of the download once it’s done? I note that you don’t mention it on your step-by-step page, but Peppermint suggest you do on their download page. I appreciate the suggested purpose, but that might be another xhrs.

If you want to check the MD5 checksum against the one from the Peppermint website … there is some free software for Windows that will generate the MD5 checksum for the downloaded ISO image here:
instructions on using it here:

But you’re not going to be installing it to the SSD immediately … you’ll be selecting “Try peppermint” … which should boot to a fully working desktop, running from the USB stick … if there are any problems, it’s unlikely to boot :wink:

Fair enough… that resolves that question then :wink:

Good username BTW, for someone that’s going to use Peppermint to get their Aspire One to “rise from the ashes” of Linpus Lite :wink:


When I DLd Peppermint two, after completion my PC automatically prompted to burn it to a CD. That was done.

Looking at that CD I see it contains sub-directories:

… and files…

Now I’m using Universal USB installer to create the stick. It’s asking me to select the .iso file, trouble is despite digging around I don’t see an .iso file.

Any ideas?


p.s. At step #1 on the installer, I have the distribution set to ‘Peppermint two’.

Hmm … you shouldn’t have let it burn the CD automatically … Windows has a bad habit of deleting the ISO image after a successful burn.
Though if you’re lucky, it may still be in your temp directory … do a search for Peppermint-Two-i386-06052011.iso

If not, you’re going to have to re-download it I’m afraid.

Right-click the link below, and select “Save As” or similar: