WEBEX audio problems LINUX 64bit systems. (Closed)

I am running mint 17.2 64bit system.

WEBEX claims to be compatible with Linux systems.

However it seems that it only works with 32bit systems on 64bit systems there are problems with audio not being detected.

Lots of suggestions the most promising seem to be installing a 32bit version of firefox onto the 64bit system or running a 32 bit version of Linux in a VM.

Would like suggestions as to which option is easiest to install and operate.

Thanks in advance.

Mint 17 should be multiarch capable, so theoretically it should just be a case of installing the correct 32bit libraries (and possibly using a 32bit browser).

Now I need to go off and figure out what you mean by WEBEX (and how to test it) … so if you can give me any clues ?? :wink:

www.webex.com is a video conferencing software. Webex Meetings

A number of my clients use it for conference calls.

It is possible to sign up for a free basic account where just 3 different parties can talk at the same time.


ls $HOME/.webex

the output will contain a directory called something like 12_1524 … if necessary adjust the next command accordingly


ldd $HOME/.webex/12_1524/*.so >>check.txt

then post the output from:

cat check.txt | grep "not found"


Okay I’ve come to the conclusion this may be possible to get working, but it’s going to be a roya l PITA … it would probably be easier just to switch to 32bit Linux

Otherwise you’re going to have to install 32bit Firefox which will uninstall 64bit firefox, and figure out all the 32bit dependencies (I was getting there when one flatly refused to install because of the 64bit version being present) … this would likely cause you other problems down the road.

The output you requested is:

userone@Office2 ~ $ cat check.txt | grep “not found”
libjawt.so => not found
libjawt.so => not found

Could I use a VM to run a light 32bit Linux version or do I need to install a duel boot?

Also suggestions is peppermint still small and light?

Sure you could run a 32bit distro in a VM … I can’t say for sure how the audio subsystems would handle things, but it can’t hurt to try.

Will give it a go…

Good luck, and please let us know how you get on.

I tried to install VirtualBox both from the package manager and from the website.

It will not install due to a missing dependency libdevmapper1.02.1 checking my system it seems that this software is already installed on my computer.


Does reinstalling it make any difference:

sudo apt-get install --reinstall libdevmapper1.02.1

Reinstalling had no impact. Dependency is not satisfiable libdevmapper1.02.1

It also says that if your running a 64bit system you can only install a 64bit VM. Dos this mean that I would not be able to install a 32bit OS in the VM?

No … I’m 99.9% sure you can install 32bit VM’s in 64bit Linux, I’ll check, then if I’m right we’ll try to figure out the dependency issue.


Yeah I had no problem running a 32bit VM in Virtualbox on Peppermint 6 64bit

I’ll now see what I can find about the dependency thing…

Can you post the output from:

uname -a

usertwo@usertwo-R59P-R60P-R61P ~ $ uname -a
Linux usertwo-R59P-R60P-R61P 3.13.0-24-generic #47-Ubuntu SMP Fri May 2 23:30:00 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux



sudo apt-get remove --purge virtualbox*


sudo gedit /etc/apt/sources.list

(you may have to change “gedit” in that command to whatever text editor Mint uses … or install gedit)

When that file opens, make sure the file contains the line

deb http://download.virtualbox.org/virtualbox/debian trusty contrib

SAVE the file and exit the text editor
if it contains a line similar to the one above but not EXACTLY like it … change it to the exact line above.

Back in the terminal run:

wget -q "https://www.virtualbox.org/download/oracle_vbox.asc" -O- | sudo apt-key add -


sudo apt-get update


sudo apt-get install linux-headers-generic build-essential dkms virtualbox-5.0

any errors ? … if so, please copy and paste them exactly as they appear in the terminal.

virtualbox has installed OK, now how do I install Peppermint 6 32bit in virtualbox?

I have an iso image on a DVD.

Click “New”

Name: Peppermint 6 32bit
Type: Linux
Version: Ubuntu (32-bit)

Click “Next”

Click “Next”

Click “Create”

Click “Next”

Click “Next”

Click “Create”

In the left hand column, double click the new “Peppermint 6 32bit” entry to start the VM

Click the little folder icon, and point it at the Peppermint 6 ISO you downloaded earlier

Then click “Start”

it should now be running like a LiveCD … so you’ll need to “Install” Peppermint in the normal way (when asked by the Peppermint installer, just tell it to use the entire disk as it’s talking about the virtual disk not your real HDD)

Installation worked OK and have installed firefox and java (required for webex).

Is it possible to change the resolution in the VM as it seems to be stuck on 640x480?

Yeah, you’ll have to install “Guest Additions” in the Peppermint VM … and you may as well install the extension pack at the same time.

In Mint, with virtualbox closed, download this file
then double-click it … it should automatically fire up virtualbox and install.

Also in Mint download this file

Now fire up the Peppermint VM

At the top of the VM window (on the menubar) go to
Devices > Optical Drive > Choose Disk Image
and point it at the VBoxGuestAdditions_5.0.14.iso file.

Now in the Peppermint VM, open a terminal and run:

sudo /media/$USER/VBOXADDITIONS_5.0.14_105127/VBoxLinuxAdditions.run

once the guest additions have finished installing, shut down the Peppermint VM … and restart it.

Now you should be able to choose different resolutions in the normal way in Peppermint (menu > Preferences > Monitor Settings)

or you can choose
View > Scaled Mode
on the Virtualbox menubar … and stretch the VM window

or both.

sudo /media/$USER/VBOXADDITIONS_5.0.14_105127/VBoxLinuxAdditions.run

This returns an error message command not found?

OK in the Peppermint VM open the file manager … you should see on the left VBOXADDITIONS … click it to mount it

Now try running:

sudo /media/$USER/VBOXADDITIONS_5.0.14_105127/VBoxLinuxAdditions.run