Windows network connection problems after installing Wubi

I am new to the forum, sorry to come straight in with a problem but I can’t find the right information anywhere.

I have just installed Wubi to try Ubuntu but I am now having big problems with my network conections in both Ubuntu and Windows.

After installing Ubuntu, when booting in my original Windows XP pro OS, I was unable to see any wireless networks but could connect through a wired connection. I updated the wireless driver but this made no difference, it appears as if the hardware switch is turned off but it is not. (When I do turn the hardware switch on and off a tone comes out the speakers as usual.)
Booting in Ubuntu is a similar situation I can connect through a wired connection but cant see any wireless networks.

And now in windows I don’t seem to be able to connect through the wired connection either, the local area network activity shows sent packets but none received.

I don’t really understand what has changed to my network devises within windows but it was working fine before installing Ubuntu.

The LAN network card is: Broadcom NetLink ™ Fast Ethernet
And wireless: Intel(R) Wireless WiFi Link 4965AGN
Installed Ubuntu 11.04-rev211

At the moment I can only access the internet through the wired connection in Ubuntu.

I will be really grateful for any help or advice that you can please offer me, Windows is unable to perform system restore, and I have some applications and files that I need to continue using in windows.

Thanks very much for any input.

Is this a laptop ? … if so can you post the make/model

Is the wireless adapter a USB device ?

If so does it have a physical switch to turn on/off the wireless… if so try booting with the switch in the OFF position, then turn it ON once booted.


Maybe something in Ubuntu is leaving the network adapters in an state where they become unusable by windows… removing all power to them should clear this, and reset them to default.

I take it you’ve tried completely shutting down the PC, rather than just rebooting ?

Can you also try this

Shut down the PC, now whilst it’s off…

If a desktop - unplug it from the mains… whilst unplugged, press the power button once (the one you’d normally hit to start the PC) to discharge any residual power… now plug it back in, and boot into Windows… does networking work ?

If a laptop - same procedure, but also remove the battery before hitting the power button to discharge.

One other question, have you tried turning your router off/on again ?

Hi Mark, thanks for the quick response.

It is a laptop, I have a Lenovo 3000 V200

The wireless adapter is not a USB device its inbuilt but it does have a physical on/off wireless switch. - I tried booting in XP with it off then turning it on, and it made a noise when I switched it on but I still could not see any wireless networks.

I just tried the discharge procedure and turning the rooter on and off, but unfortunately no luck.

I think that in Ubuntu the wired connection is working fine and the wireless just doesn’t have the correct driver at the moment.
But in windows I don’t seem to be able to receive any data though either the wired or wireless network adapters.

In Ubuntu, can you open a terminal, and send the output from these 2 commands:

sudo lshw -C network


rfkill list

First command -
charlie@ubuntu:~$ sudo lshw -C network

description: Ethernet interface
product: NetLink BCM5906M Fast Ethernet PCI Express
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:05:00.0
logical name: eth0
version: 02
serial: 00:16:d3:bf:5f:b7
size: 100Mbit/s
capacity: 100Mbit/s
width: 64 bits
clock: 33MHz
capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.116 duplex=full firmware=sb v3.04 ip= latency=0 link=yes multicast=yes port=twisted pair speed=100Mbit/s
resources: irq:46 memory:f4200000-f420ffff
*-network DISABLED
description: Wireless interface
product: PRO/Wireless 4965 AG or AGN [Kedron] Network Connection
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:06:00.0
logical name: wlan0
version: 61
serial: 00:1d:e0:08:53:4d
width: 64 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
configuration: broadcast=yes driver=iwlagn driverversion=2.6.38-8-generic firmware= latency=0 link=no multicast=yes wireless=IEEE 802.11abgn
resources: irq:44 memory:f4300000-f4301fff

Second command-
charlie@ubuntu:~$ rfkill list
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: acer-wireless: Wireless LAN
Soft blocked: yes
Hard blocked: no
2: phy0: Wireless LAN
Soft blocked: yes
Hard blocked: yes

Try running this command:

sudo rfkill unblock all

and see if the wireless starts working in Ubuntu

I can now click “Enable Wireless” in the drop down menu at the top right, but it has not automatically found any networks

can you see if acer_wmi is loaded

lsmod | grep acer_wmi

and let me know if anything is returned.

This was returned -

acer_wmi 23771 0
sparse_keymap 13898 1 acer_wmi

Try this…

sudo modprobe -r acer_wmi

Does wireless sping to life ?

if not can you send the total output from:


Yes it has just come to life and connected to my router, that great thanks

Not done yet, we need to blacklist that driver, so it doesn’t load next time you boot the PC…

open a terminal, and enter:

sudo -s


echo "blacklist acer_wmi" >> /etc/modprobe.d/blacklist.conf



now reboot to Ubuntu and check wireless still works.

Ahh, it seems to have gone back to how it was now

see above… did you do that ?

Yep I did the black list bit

Can you send the contents of this file when it opens:

gedit /etc/modprobe.d/blacklist.conf

and the output from



rfkill list

Just messaged you the content of the file,

charlie@ubuntu:~$ lsmod
Module Size Used by
nls_utf8 12557 1
nls_iso8859_1 12713 1
nls_cp437 16991 1
udf 93525 1
vfat 21708 1
fat 61374 1 vfat
parport_pc 36959 0
ppdev 17113 0
rfcomm 47694 8
binfmt_misc 17565 1
sco 18131 2
bnep 18308 2
l2cap 53570 16 rfcomm,bnep
joydev 17606 0
snd_hda_codec_conexant 57511 1
arc4 12529 2
snd_hda_intel 33211 2
snd_hda_codec 103804 2 snd_hda_codec_conexant,snd_hda_intel
snd_hwdep 13604 1 snd_hda_codec
snd_pcm 96625 2 snd_hda_intel,snd_hda_codec
snd_seq_midi 13324 0
snd_rawmidi 30486 1 snd_seq_midi
iwlagn 333500 0
snd_seq_midi_event 14899 1 snd_seq_midi
i915 514985 3
snd_seq 61621 2 snd_seq_midi,snd_seq_midi_event
iwlcore 167503 1 iwlagn
mac80211 294370 2 iwlagn,iwlcore
snd_timer 29602 2 snd_pcm,snd_seq
gspca_m5602 65289 0
snd_seq_device 14462 3 snd_seq_midi,snd_rawmidi,snd_seq
gspca_main 36853 1 gspca_m5602
videodev 82052 1 gspca_main
btusb 18600 2
r852 18246 0
sm_common 16817 1 r852
nand 55112 2 r852,sm_common
nand_ids 12723 1 nand
drm_kms_helper 42136 1 i915
v4l2_compat_ioctl32 17078 1 videodev
snd 67382 13 snd_hda_codec_conexant,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
bluetooth 72448 9 rfcomm,sco,bnep,l2cap,btusb
psmouse 73535 0
nand_ecc 13230 1 nand
cfg80211 178528 3 iwlagn,iwlcore,mac80211
serio_raw 13166 0
mtd 27900 2 sm_common,nand
soundcore 12680 1 snd
drm 227495 4 i915,drm_kms_helper
i2c_algo_bit 13400 1 i915
snd_page_alloc 18529 2 snd_hda_intel,snd_pcm
video 19438 1 i915
lp 17825 0
parport 46458 3 parport_pc,ppdev,lp
mmc_block 18053 2
sdhci_pci 13989 0
tg3 141750 0
firewire_ohci 40370 0
sdhci 27387 1 sdhci_pci
firewire_core 62646 1 firewire_ohci
crc_itu_t 12707 2 udf,firewire_core

charlie@ubuntu:~$ rfkill list
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes


sudo rfkill unblock all

work ?

if so, we’ll have to find a way of running that at boot up.

That doesn’t seem to have worked this time.

I tried “rfkill list” after and it gave me the same result as before,

charlie@ubuntu:~$ sudo rfkill unblock all
[sudo] password for charlie:
charlie@ubuntu:~$ rfkill list
0: hci0: Bluetooth
Soft blocked: no
Hard blocked: no
1: phy0: Wireless LAN
Soft blocked: no
Hard blocked: yes

OK, for the time being, lets put it back the way it was:

gksudo gedit /etc/modprobe.d/blacklist.conf

Scroll to the bottom, and remove the line that reads -

blacklist acer_wmi

SAVE the file and exit gedit.

Reboot into Ubuntu, and see if these commands get the wireless working:

sudo rfkill unblock all


sudo modprobe -r acer_wmi

If that works, I suppose we could look into creating a script that runs at bootup, that runs those 2 commands… but I’d prefer to find a “proper” fix.

BTW, did you (at any time) reboot and try Windows ? (I’m NOT asking you to, I just want to know if you did)